If bookmarks.html is a symbolic link Mozilla breaks it upon exiting

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
15 years ago
5 years ago

People

(Reporter: beat.kappert, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

If bookmarks.html is a symbolic link to a file somewhere else, that link is
broken and replaced by a COPY of the bookmarks when Mozilla exits.
This breaks my way of sharing bookmarks between Linux and Windows on a dual-boot
system.

Reproducible: Always

Steps to Reproduce:
1. mv bookmarks.html elsewheremarks.html
2. ln -s elsewheremarks.html bookmarks.html
3. ls -l bookmarks.html (it's a symbolic link)
4. Start Mozilla
5. Exit Mozilla
6. ls -l bookmarks.html (not a symbolic link anymore)


Actual Results:  
bookmarks.html is not a symbolic link anymore but a copy of elsewheremarks.html.

Expected Results:  
Leave the symbolic link in place.

This bug was fixed earlier and has now been re-introduced (see #156814).
Has already been reported against Firebird as #206567, but I am still using
Mozilla and hope it can be fixed in Mozilla, too.
Whiteboard: DUPEME
(Reporter)

Comment 1

15 years ago
WORKAROUND EXISTS! (or better said: a superior solution)

A comment to bug 178005
  http://bugzilla.mozilla.org/show_bug.cgi?id=178005
says:
"Most (if not all) apps in Linux will replace a symlinked file with a regular
one;"
And as far as I can remember from other comments solving this link issue depends
on some incomplete features of a library used by Mozilla. So it is essentially
out of reach for the Mozilla developers or they do something ugly. Sorry, can't
find these comments anymore.

But the above comment also points to a perfect solution:
http://texturizer.net/phoenix/tips.html#beh_bookmarks

... just specify the location of the bookmarks by creating "user.js" and add a
line like this:
user_pref("browser.bookmarks.file", "/somewhere/else/bookmarks.html");
  or on Windows:
user_pref("browser.bookmarks.file", "C:\\Somewhere\\Else\\bookmarks.html");

(Beware, there is some automatism which copies parts of user.js to prefs.js.
This can get in the way when you want to get rid of an entry in user.js).

Defining the location in user.js is the better solution than having a link.
Given this perfect solution I would say it is enough to advertise this approach
and close this class of bugs. It would be cool if the location of the bookmarks
could be specified in the GUI.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.