Apache web server does not have the ability to send NO mime-type

RESOLVED INVALID

Status

Tech Evangelism Graveyard
Other
--
major
RESOLVED INVALID
14 years ago
3 years ago

People

(Reporter: S Woodside, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030721 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030721 Camino/0.7+

The Apache web server does not have the ability to send /no/ MIME type. Normally
this is not a problem as apache comes pre-configured with a fairly extensive set
of mime types already known. However, there is a significant problem when the
apache server does not know the mime type, because currently it sends a DEFAULT
mime type, which is text/plain. text/plain is not always appropriate.

Mac OS X users get with this pretty bad because a lot of apache servers don't
know about .DMG extension which should be sent as application/octet-stream and
is instead sent as text/plain which shows up as garbage characters and ruins
many downloads.

There is already an Apache bug open on this subject. See
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13986 "Remove the default MIME
type". Please read at least the comment of Joshua Slive 2003-02-07 16:19. He
seems to agree that apache should default to NO mime type (omitting the
Content-Type header) but refers further discussion/arguments to the mailing
lists dev@httpd.apache.org or users@httpd.apache.org.

If Apache actually removes the default MIME type this would be a big win for
Mozilla. We would be able to maintain standards compliance with the RFC and get
the behaviour we want as well. Other browsers in general would also benefit. If
the evangelism team can help that would be very useful.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
related: bug 175848, bug 221877, bug 192410
This doesn't belong into Tech Evangelism.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.