Mozilla/Firebird needs its own Bit Torrent client

VERIFIED DUPLICATE of bug 203571

Status

()

Toolkit
Downloads API
--
enhancement
VERIFIED DUPLICATE of bug 203571
15 years ago
10 years ago

People

(Reporter: Lucian, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
Build Identifier: Mozilla/5.0 (en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)


As a feature and due to the popularity and usefulness of this format it would be
wise for Mozilla/Firebird to intergrate Bit Torrent into Mozilla itself. This
would help with upgrading, patching the Mozilla client, and ease the stress on
the Mozilla servers.


Reproducible: Always

Steps to Reproduce:
1. Go to random bit torrent site such as animesuki.com
2. Attempt to Download a .Torrent
3. Watch as Mozilla/Firebird has no clue about what that is.

Actual Results:  
Mozilla does not handle .torrent

Expected Results:  
Now, I know you can always download your own client, but I think it would be
very useful for Mozilla to provide one with the install, the client would not
have to be sophisticated just functional

I think it would be useful to put basic .torrent handling functionality into
mozilla/firebird, I see no point in having to download a special .torrent
downloader when mozilla can just built one into the product, I'm guessinng
almost an equal number of people use bit torrent to the people that actually use
mozilla/firebird.

Comment 1

15 years ago
Even the BitTorrent developers don't see the logic in doing that.  Reference bug
203571 comment 13.

*** This bug has been marked as a duplicate of 203571 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
As an additional comment, I'd also like the Mozilla team to investigate the
impact of allowing Mozilla to handle .torrents in the same way the Mozilla
browser handles .html, could we have .torrent based webpages as a result if the
information for the site were stored and distributed via .torrents?

Of course this could have its advantages or disadvantages but the advantages do
make sense if its a popular site such as slashdot, or if its a site which just
got slashdotted and people are looking for mirrors.mailto:sairuh@aol.net
(Reporter)

Comment 3

15 years ago
And I dont see why we shouldnt do it, Mozilla already seems to do everything
else, from FTP client,IRC client,download manager.

If the main purpose of a browser is to handle web based content I'd think
handling  .torrents gracefully would be at least more important than spell
checker, and having a fancy download client, or at least I should say it would
be more important to the *masses* to have features such as support for .torrents,

Of course theres always Konqueror.
(Reporter)

Comment 4

15 years ago
I wish this site allowed me to edit previous statements but 

"But even if any data of the second kind is indeed embedded into a website (like 
a video, although I never watch video embedded in my webbrowser), it's not a 
good idea to bind this embedding process to BitTorrent, because 
every "BitTorrent connection" has a lifespan which need to be specifed by the 
user himself. A file keeps being uploaded after its download completes within 
BitTorrent, until the user decides to "finish" this file."

This was stated by the "BitTorrent" developer. To avoid a flame war I'd like to
state that i'm not really asking for BT to be embeded into Mozilla what I'm
really asking for is for it to be handled officially by the mozilla download
manager instead of having me download a client, you know?

Hopefully this clears it up but my bug is not an exact dupe of the other bug, i
want a upgrade to the download manager already developed, and if .torrent
continues to improve as a protocl perhaps in a while then we will see
torrent://blahblah.torrent

Comment 5

15 years ago
verified dupe.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.