Vertical scrollbar not long enough when images (without width/height) are loading

RESOLVED DUPLICATE of bug 219220

Status

--
minor
RESOLVED DUPLICATE of bug 219220
15 years ago
14 years ago

People

(Reporter: rick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031018
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031018

If you view the specified page with your browser window fairly small (say 1024 *
768 or less) you should find that the vertical scrollbar does not scroll the
full length of the page after the images are loaded. It seems as though the
scrollbar's max value is calculated before images are loaded, and not updated
again once they've finished. I'm not sure if this is specific to the Dabs site;
I wouldn't have thought so. Also if you resize the window (horizontally) the
scrollbar works as expected. I think it may also have something to do with the
table being quite wide.

Reproducible: Always

Steps to Reproduce:
1. Load specified page
2. Wait for page to finish (incl. images)
3. Try to scroll down to the bottom

Actual Results:  
Viewport doesn't scroll down to the bottom of the page

Expected Results:  
Scrolled all the way down to the bottom
(Reporter)

Comment 1

15 years ago
Sorry to spam, but I forgot to mention you will need to make sure your browser
hasn't cached the images on that page (or try a different search on
http://www.dabs.com/ that brings up a lot of items) otherwise the scrollbar
problem probably won't occur.

Comment 2

15 years ago
I can't confirm this behavior on build 2003101804. 

Comment 3

15 years ago
I see the problem: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a)
Gecko/20031017 Firebird/0.7+ (aebrahim)

this is a possible duplucate of bug 204200
(Reporter)

Comment 4

15 years ago
I'm pretty sure this isn't a dupe of bug 204200 as that is with regards too a
CSS overflow + height problem.

Comment 5

15 years ago
This problem is very much related to height and overflow.

Deeply nested within tables there is a <div id="content"> which is styled with
'height:100%'.  This <div> contains the table with the search result (all the
product infos).  The computed height of this <div> is too small to fit its
contents, so it overflows and this overflow is somehow lost in the deep
nesting of tables, so it's not visible and the wrong height is reported to the
vertical scrollbar.  I'm guessing the cause for all this is that the images are
a bit slow to load, which explains why it works when they are cached...
This is the same problem as in bug 219220

*** This bug has been marked as a duplicate of 219220 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
OS: Windows XP → All
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.