clicking link to save a file, dialog won't follow folder shortcut .lnk to new destination, tries to overwrite shortcut

VERIFIED INVALID

Status

()

Toolkit
Downloads API
VERIFIED INVALID
14 years ago
9 years ago

People

(Reporter: Slain Wilde, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When downloading a file directly (ie. not from a cgi or download manager, etc.) by clicking on a url link to a file (.zip, etc.), shortcut .lnk links in Windows are not navigated through in the save dialog.  Instead the app tries to save the file as the link name.

This only happens when directly downloading a file by clicking on it.  This works properly when you right click 'save link to disk' or try to save a webpage or various other open and save dialogs.
 

Reproducible: Always

Steps to Reproduce:
1. Create a shortcut in one folder that points to another folder.
2. Click on the supplied url (or any url that tries to save a file directly).
3. Navigate to the shortcut that was created, and try to follow the shortcut.
Actual Results:  
Firebird tries to save the file as the shortcut (.lnk) filename.

Expected Results:  
Firebird should follow the shortcut link to the new folder.  This problem did not occur in .61.
WFM in:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20040102
Firebird/0.7+

I think this might possibly be an issue with the settings on your computer, if
anything.  Mozilla Firebird has always used the system file save dialog, so the
behavior shouldn't have changed.  Anyways, though, if you see it again in
Mozilla Firebird 0.8 (out probably within two weeks, perhaps a day or two more),
feel free to comment here; we'll worry about this then if it pops up again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Reopening based on comments from reporter (who couldn't post because of
screwiness in the fixing of bug 233501).  Contents of his email to me are as
follows:

===

(I am unable to put this in Bugzilla as it no longer
recognizes Firebird as a legal product name, but there
is no Firefox entry).

This bug still occurs in FireFox.  It occurs on
multiple computers.  Click on a link that pops up the
Mozilla Open/Save As option, choose Save As.  The
navigate to a shortcut that points to another folder. 
Try to doubleclick on the folder to navigate to the
shortcuts destination.  Firefox attempts to overwrite
the file.

ADDITONAL INFO:
If while in the dialog, you type something that globs
filenames ( such as *.txt even if there are no *.txt
files), then doubleclick on your folder shortcut, it
will follow the link as expected.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

14 years ago
WFM in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040302
Firefox/0.8.0+

Can anyone else reproduce this issue?
Assignee: firefox → bugs
QA Contact: aebrahim

Comment 4

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040302
Firefox/0.8.0+

WFM as well.

Comment 5

14 years ago
Reporter, could you try to reproduce this with one of the builds from here:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Please create a new profile to test, or delete your old profile. Please also
disable any extensions that you might be using.

Let us know if it works for you with a new build from here, a clean profile, and
no extensions.
(Reporter)

Comment 6

14 years ago
Deleting my profile worked.  Thanks for the suggestion.  Sorry for the trouble,
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID

Comment 7

14 years ago
v
Status: RESOLVED → VERIFIED
*** Bug 286824 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.