[Dogfood][CRASH] download dialog crashes after hitting close button

VERIFIED WORKSFORME

Status

()

Core
Event Handling
P3
critical
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Judson Valeski, Assigned: joki (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
after downloading a file and clicking "close" I crash. Winnt, m13 code.

Updated

18 years ago
Assignee: law → joki
Component: Browser-General → Event Handling

Comment 1

18 years ago
I reproduced this on my machine.  After some debugging, it looks like the
problem is (or appears) inside the "event state manager?"  I'm going to reset
the component to "Event Handling" for further investigation.

Updated

18 years ago
Severity: normal → critical

Comment 2

18 years ago
*** Bug 22416 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
I have a feeling this bug is identical to bug 22234.
Both are crashes that happen when you exit a popup window. Someone else might
want to mark this a duplicate of bug 22234 if they can verify they're the same.

Updated

18 years ago
QA Contact: nobody → janc

Comment 4

18 years ago
Updating QA Contact.
Summary: download dailog crashes after hitting close button → [CRASH] download dialog crashes after hitting close button
Marking [CRASH].
(Assignee)

Comment 6

18 years ago
Moving crash bugs into M13.

Comment 7

18 years ago
This bug is still happening despite bug 22234 not happening anymore. And it's
parent bug 22360 being fixed... I think whoever is working on this bug might
want to read bug 22360 just to make sure that they're not related.

Comment 8

18 years ago
*** Bug 22575 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Is bug 22481 related? They are very similar except that in bug 22481, a simple
File -> Save page As does not crash. It has to be done from the View Source
window. Bug 22481 was first noticed with M12, and File -> Save As now crashes
from View Source and the browser window in builds after M12.

Comment 10

18 years ago
Dulicated this on my machine (Build 1999122608 on WinNT4 SP5). Here are the log
messages on the console:
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
In OpenBrowserWindw()...
WEBSHELL+ = 5
nsXULKeyListenerImpl::Init()
WEBSHELL+ = 6
Setting content window
browser.startup.page = 1
startpage = http://www.mozilla.org/
Loading page specified via openDialog
Check if a view source window
Document http://www.mozilla.org/ loaded successfully
Document: Done (1.833 secs)
WEBSHELL+ = 7
frame forContent DragGesture
FindShortcut: in='http://172.18.18.234/'  out='null'
Document http://172.18.18.234/ loaded successfully
Document: Done (0.791 secs)
DocLoaderFactory: Unable to create ContentViewer for command=view, content-type=
application/octet-stream
Document: Done (0.21 secs)
WEBSHELL+ = 8
Error: Can't load: http://172.18.18.234/Download/IDE/lccwin32.exe (804b0002)
Error loading URL http://172.18.18.234/Download/IDE/lccwin32.exe
WEBSHELL+ = 9
WEBSHELL- = 8
After Download completes and 'OK' button pressed:
--------------------------------------------------
WEBSHELL- = 7
Crash occurs here!
-------------------
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I also managed to get a crash log - looks like the guilty function is
NS_NewXMLDocument.
See crash log attached below.

Comment 11

18 years ago
Created attachment 3855 [details]
Dr. Watson Crash Log for the bug.

Comment 12

18 years ago
This is probably related to bug 22488 , in both cases, the crash occurs in
NS_NewXMLDocument when clicking a button in the popup window. Not being sure, I
did not mark it as duplicate - anybody care to investifate this further ?

Comment 13

18 years ago
This bug is probably a duplicate of, or at least strongly related to bug 22554.
Anybody working on this should definitely have a look at bug 22554 as well.

Updated

18 years ago
Summary: [CRASH] download dialog crashes after hitting close button → [Dogfood][CRASH] download dialog crashes after hitting close button

Comment 14

18 years ago
bug 22554 which is PDT+ is marked as a dup of this bug.
Adding dogfood designation so it can be considered for PDT + (again)
would this bug be dependent on the fix for bug 10613 perchance?

Updated

18 years ago
Whiteboard: [PDT+]

Comment 16

18 years ago
Putting on PDT+ radar.

Comment 17

18 years ago
*** Bug 22744 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 18

18 years ago
This isn't happening anymore on WinNT 2000010908 build. Did someone fix it?
I'm marking Worksforme - I noticed that all the related "Crash on closing
window/dialog/popup" are all working fine now too.

Comment 19

18 years ago
I'm not sure I agree with you.  I'm trying to test this bug, but build
2000010908 (Win95) is page faulting all over the place.  To make things worse
half the things I try to download stall the browser with an "Unable to load
content viewer" error in the console window.  I have had atleast three crashes
while trying to download, but due to the high number of unexplicable crashes,
I'm not confident enough to remove the WORKSFORME flag.  But all is definately
not well.

Comment 20

18 years ago
Okay, I narrowed down some of the download trouble.  It appears as though some
downloads are causing the download window not to display the "close" button
when they are done.  Others are and are working fine.  And still others (.exe
files) do not seem to even create a download window.  All this though is
probably a regression and not related to this bug.  I am leaving the WORKSFORME
flag as it looks like this bug was indeed fixed.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 21

18 years ago
verified
You need to log in before you can comment on or make changes to this bug.