RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: Evgueni Astigeevich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5) Gecko/20031017
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.5) Gecko/20031017

The Mozilla 1.5 browser crashes in case when the page
http://www.w3.org/TR/2003/WD-DOM-Level-3-Core-20030609/core.html is opened.

The Mozilla 1.4 browser does not crash on this page.

OS: Solaris Sparc 5.8
Mozilla built flags: --disable-ldap --enable-crypto --disable-mathml
--disable-tests --enable-optimize=-xO2 --disable-debug
GTK: 1.2.10 (compiled by Forte)
GLib: 1.2.10 (compiled by Forte)
Compilers: Sun WorkShop 6 update 2 C 5.3 2001/05/15

All required patches are installed.

Reproducible: Always

Steps to Reproduce:
1. Open the page http://www.w3.org/TR/2003/WD-DOM-Level-3-Core-20030609/core.html

Actual Results:  
The browser crashes.

Expected Results:  
The browser should display the page.
worksforme with a Linux gcc build, so sounds like something Solaris or Forte
specific...
reporter is core generated ? If so could you reproduce the bug with
--debug-enabled and attach the core files gziped to the bug ?
(Reporter)

Comment 3

15 years ago
Unfortunately I cannot attach a core. I always get a message "Invalid attachment
id." Maybe this is because I am behind firewall.

I will dowload a mozilla build from mozilla.org and try it.
(Reporter)

Comment 4

15 years ago
I downloaded mozilla-sparc-sun-solaris2.8_1.5.tar.gz from mozilla.org and
installed when I ran it I got the following messages:

Gdk-WARNING **: gdk_font is NULL or not a fontset.
Gdk-WARNING **: gdk_font is NULL or not a fontset.
Gdk-WARNING **: gdk_font is NULL or not a fontset.
Gdk-WARNING **: gdk_font is NULL or not a fontset.
Gdk-WARNING **: gdk_font is NULL or not a fontset.
Gdk-WARNING **: gdk_font is NULL or not a fontset.

And application hanged.

I appreciate any help.
(Reporter)

Comment 5

15 years ago
The downloaded mozilla started working and displayed the page when I changed
LD_LIBRARY_PATH. I replaced path to my gtk library by path to the gtk library
from Netscape 7.

So the problem was in the gtk library, so the bug can be closed as 'not a bug'.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.