[UI] Javascript errors in create profile wizard

VERIFIED FIXED in M14

Status

P2
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: selmer, Assigned: bugs)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
build 1999122109
Here is the console message:

JavaScript Error: TypeError: prefix has no properties
URL:
chrome://global/content/widgetStateManager.js
LineNo: 271

This happens when I hit the Next button on the first page of CPW.  At least one
time, I did not get this error and actually progressed through the wizard.

Updated

19 years ago
Summary: Javascript errors in create profile wizardh → [UI] Javascript errors in create profile wizardh

Comment 1

19 years ago
Adding UI tag to the summary line. Makes isolation of UI bugs easier.
okay that's just weird. (I've said that before, too... ¬_¬)

my code looks okay.. it's passing in strings into the function where this error
occurs. the only reason I can think of where you wouldn't get this is that the
string tag is undefined (and hence with no length property). I can't understand
why this would be so though, I've never seen it and can't see it today's build.
please let me know if this continues.

Comment 3

19 years ago
I am seeing this in build 1999122208 on Linux so far.  I can create one profile
per ProfileManager session. Subsequent attempts to create additional profiles
give me the error message noted above

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M13

Comment 4

19 years ago
M13 ...
*** Bug 22557 has been marked as a duplicate of this bug. ***
hm.. I wonder if this is some sort of back end regression. I have code in a
build from 12/10 that does not exhibit this problem, however when I copy the
profile chrome folder from that build into one from a couple of days ago it
shows the problem.
Component: Profile Manager → XP Utilities
Target Milestone: M13 → M14
push back until I can find a new owner for this... (supposedly its brutal
sharing)...
I think waterson has a fix in his tree for a bunch of brutal sharing bugs (that
were previously mailnews bugs).

perhaps this should be re-assigned to him?

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

19 years ago
marking fixed: i'm not seeing these anymore after checking in a fix to 22915

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
not seeing these either, rechecked on build 2000011313

Updated

17 years ago
Component: XP Utilities → Profile Manager FrontEnd
Summary: [UI] Javascript errors in create profile wizardh → [UI] Javascript errors in create profile wizard
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.