If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When using the Hebrew UI, mail/news password db incorrectly defaults to Hebrew

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Shoshannah Forbes, Assigned: mkaply)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; he-IL; rv:1.4) Gecko/20030624

When using the Hebrew UI, mail/news password db incorrectly defaults to Hebrew-
as passwords are in latin characters, and the user doesn't see what he/she is
entering, this leads to many incorrect passwords.

Steps to reproduce:
1. set mail/news not to remeber the passwords (they should ask every session)
2. make sure that your keyboard is set at english
3. check mail- you will get a password prompt
4. just enter your password

Results: 

As Mozilla unexpectly switched the input language to Hebrew, you end up entering
an incurrect password and getting an error.

Expected: 

Mozilla should not switch the input language on it's own, so you can enter your
password properly

Comment 1

14 years ago
Tsahi, when possible, please test the Hebrew UI with the current trunk build and
verify whether the fix for bug 162242 has indeed solved this one as well. If it
has, then this bug should be Marked as WORKSFORME.

Prog.

Comment 2

14 years ago
shosh, what do you mean by "db"?

even if i check this now with just the RTL-ing CSS file and it works fine, i
would still need to check it with a language pack, that also includes some
default encoding. so i suggest we will wait with this until i make a pack for
1.6, shortly after it's released.

Comment 3

14 years ago
Tsahi wrote:
> so i suggest we will wait with this until i make a pack for 1.6, shortly after
it's released.

That's assuming the fix lands on this branch. If it doesn't get approval1.6,
you'd have to wait for 1.7

Prog.
(Reporter)

Comment 4

14 years ago
db=dialog box
Product: MailNews → Core

Comment 5

11 years ago
In the Hebrew version of Thunderbird 1.5, the password dialog box is set to LTR.

This can be set easily through the intl.css or userChrome.css files by the following code:

#password1Textbox, #password2Textbox, #loginTextbox
{
   direction: ltr !important;
}

Comment 6

11 years ago
Since bug 162242 (Bidi language auto-switching) solved and the feature removed years ago, I don't think the bug still exist in latest versions. I guess we can close this bug as invalid, unless I don't understand the point of this report. 

Comment 7

11 years ago
i think we should make sure it doesn't exist before we close. i hope to do it tomorrow.

Comment 8

11 years ago
well, using hebrew thunderbird 1.5.0.7 on winxp sp2 with hebrew support, i don't see this. but it's not invalid; it's fixed or wfm.
FIXED per comment 6 and comment 8
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: MailNews: BiDi Hebrew & Arabic → Layout: Text
QA Contact: giladehven → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.