Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: Tom Schneider, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030518
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030518

I wanted to search for tumor AND also search for tuberculosis, repeatedly,
on a single page.  So I would have to type each of these in again and again.
The search window could allow me to set up multiple searches IN DIFFERENT
COLORS, simultaneously.  Google does a thing like this.  If you search for
a bunch of terms and they are found in a pdf, google will produce an html
page with EACH term in a different color.  The results are spectacularly
easy to read.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Is this similar to bug 65876?
(Reporter)

Comment 2

15 years ago
I found bug 65876 but could not make heads or tails of it, especially 
given the unanswered (for more than a year!) comment,
"From Erich 'Ricky' Iseli  2002-09-27 06:38 
What's this about? can anyone enlighten me?" ... so I figured it
was better to suggest it than it be lost ...

Comment 3

15 years ago
This seems to be about the "Find in This Page..." dialog, correct?
(is which case it is not a duplicate of bug 65876)

-> over to XP Apps
Component: Search → XP Apps: GUI Features
OS: MacOS X → All
Hardware: Macintosh → All

Comment 4

15 years ago
Reassigning...
Assignee: shliang → guifeatures
Confirmed as RFE.
Should this depend on bug 65876 ?

Reporter: could you please clearify the subject a bit ? Like 'searching on page
should support logical (AND OR NOT) operators" or something like that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Whiteboard: DUPEME
(Reporter)

Comment 6

15 years ago
Well, there could be AND and OR, that would be nice,
but it was not what I was thinking.

When I do searches the words show up with a green rectangle
behind them.  I don't recall if this can be set or not.

The kind of search I was thinking of would be like an OR search except
that each term would be assigned its own color.

How about we assign t to be green and i to be red. 

Then "Something like this." would be rendered:

"Some<font color = "green">t</font>h<font color = "red">i</font>ng 
l<font color = "red">i</font>ke <font color = "green">t</font>h<font 
color = "red">i</font>s."  

That's what google does for multiple search terms in PDFs that are
converted to html for display, except it's for words.
Product: Core → Mozilla Application Suite

Comment 7

13 years ago
I closed out bug 65876

Multiple search items as you've described would require a completely different
dialog.  It really wouldn't be sufficiently useful to include in the suite,
although you could do an extension.  Matching a regular expression might suffice
and would be more useful (although most people don't understand regex) and is
already filed as bug 32641.  Highlighting all matches of a single item is bug 62467.

closing this out as WONTFIX
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: qawanted
Resolution: --- → WONTFIX
Whiteboard: DUPEME

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.