lose keyboard when you view the about page

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
15 years ago
13 years ago

People

(Reporter: ssharma, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

After viewing the Help->About page, none of the keyboard controls work.  You can't:

- Alt-T to open a tab
- Alt-W to close the window
- click in the address bar to type in a new window
- Crtl-F to open the find box...
- etc...

The only thing you can do is restart the browser.  I've been having this problem
for a while now but this is the first time I've been able to recreate it.

Reproducible: Always

Steps to Reproduce:
1.  go to help, then select "about mozilla firebird"
2.  close the about box.

Actual Results:  
You will lose all keyboard controls.  No keyboard shortcuts work, you can't
input text into a text box, etc...  

Expected Results:  
It should've just closed the about window and let me continue using keyboard
shortcuts.

I'm using blackbox on Redhat 9, but I've been able to recreate this in Openbox
2.2 (and all versions of 3.0) on Gentoo as well.  

Also, when this problem happens, all other applications are normal.  So even
after I lose the keyboard in Mozilla, I'm able to click over to another
application and have it work just fine.  This is a Mozilla/Firebird issue.

Comment 1

15 years ago
This works for me on both the 0.7 release and a self-compiled nightly build from
2003-10-19 on WinXP.
QA Contact: bugzilla
(Reporter)

Comment 2

15 years ago
GRRRR.... After I submitted this bug I tried to recreate it and I couldn't. 
Somone has to have experienced this problem before.  It's been driving me crazy
for months.  

What usually happens is that at random times the keyboard would just drop off. 
I haven't been able to track it down to a specific site --- **** --- It just
dropped out!  But this time it only dropped out for like 10 seconds.  This is so
weird...  Is there any kinda debugging log I can view to figure out what's
happening?  Like a "MozillaFirebird -vv" or something?
(Reporter)

Comment 3

15 years ago
YES!  I found another way to confirm this bug.  Here are the steps...

1) go to http://www.jobsmyway.com/
2) fill in the 'First Name' field.
3) submit the form by clicking on "Get It Now"
4) A javascript alert should come up saying that you need to fill in the Last Name
5) click "ok" to close the javascript alert box and you lose the keyboard focus.

I'm still using the 0.7 release of Mozilla Firebird, not a nightly build.  I
tested this out on Windows but it works fine.  And finally, I had a javascript
console open and there were no javascript errors on the page.

Please try to confirm this bug, I know I can't be the *only* one with this problem.

Comment 4

15 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031107
Firebird/0.7+

Comment 5

15 years ago
Ajay, your test URL given in comment 3 is no longer valid. Do you have another
testcase?
(Reporter)

Comment 6

15 years ago
*sigh*  This is driving me crazy...  

I just went through my steps in comment #3 and it works fine for me now.  And I
didn't change anything on my system.  Is it okay to leave this uncomfirmed and
I'll continue to search for a way to verify this bug.

Sorry to waste everyone's time, but it's really annoying when you have 10 tabs
open and you have to restart the browser because you lose the keyboard focus.

Comment 7

15 years ago
Ajay, if you can't reproduce it anymore this WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.