Mozilla 1.5 locks up after launch. Gdk-Warning errors issued.

RESOLVED EXPIRED

Status

--
critical
RESOLVED EXPIRED
15 years ago
13 years ago

People

(Reporter: sfergus, Unassigned)

Tracking

Trunk
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20030701
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.5/mozilla-sparc-sun-solaris2.8_1.5.tar.gz

Installed Mozilla 1.4, launched it. Everything is fine. Two days later 1.5 is
released and I install and launch it. It gives these two errors:

/projects/mozilla_1.5->./mozilla

Gdk-WARNING **: gdk_font is NULL or not a fontset.


Gdk-WARNING **: gdk_font is NULL or not a fontset.

The window launches, and I have no buttons or any picture. I do have the
title of the mozilla.org page "Getting involved with mozilla" and that is it.
All processing of CPU is finished as if it has loaded. It is like a kiosk
window. I can't do anything like select "close". I have to kill it from the
command line.

SunOS 5.8 Generic_108528-20 sun4u sparc SUNW,Sun-Blade-100
GNOME 2.0

Again, I just installed your 1.4 gzip, it worked. 

Reproducible: Always

Steps to Reproduce:
1.unpack .gz file
2.run ./mozilla
3.kill %1

Actual Results:  
Mozilla browser launches and you can do nothing at all. I am labeling Critical
because this is something that should be working out of the box. 

Expected Results:  
Mozilla browser launches with intro page and you can surf web.

Comment 1

15 years ago
Does this problem still occur if you start with a new profile?
I've seen a few funnies with profiles created from earlier versions of Mozilla
not working properly on Mozilla 1.5
(Reporter)

Comment 2

15 years ago
I have checked the patches, and I am either up-to-date or beyond what is necessary. 

We have an account which we always "test" with the first time we install new
mozilla clients. This one performed the same or or segment fault--ed. We would
always try with the old profile, then if there was an issue, rename everything to
(blah).old and launch again. 

I tried it on my account (I use 1.4) and I get the (lockup look) and I renamed my
.mozilla to .mozilla.old and launched, same results.

Recapping, I launch, it comes up gray (the whole browser). The outline of the
browswer shows the title on top. (Welcome to Mozilla or something like that) and
the bottom does not give me the browser, mail, address book, etc icons, it just
says "Done" As if it already loaded the page. I then cannot hit the top right
X button to kill it, I have to do a "kill -9" to get rid of the browser.

Comment 3

15 years ago
If you run the TestGtk program in the mozilla directory and click on the File ->
Test Stream option, do you get the 'Hi there' message.

Can you also do a library check on the mozilla-bin binary in the mozilla
directory using  the command...
/usr/bin/ldd mozilla-bin

and include the output of the ldd.
The problems that you are describing sound like a problem with the gtk1.2.x
libraries on your machine.
(Reporter)

Comment 4

15 years ago
Created attachment 134850 [details]
out is correct for TestGTK program
(Reporter)

Comment 5

15 years ago
Below is the output from mozilla 1.4 and 1.5

sunws327: /home/tlabai/sfergus/projects/mozilla->ldd mozilla-bin 
	libmozjs.so =>	 /opt/gnome/lib/libmozjs.so
	libplds4.so =>	 /opt/gnome/lib/libplds4.so
	libplc4.so =>	 /opt/gnome/lib/libplc4.so
	libplc4.so (NSPR_4.0) =>	 (version not found)
	libnspr4.so =>	 /opt/gnome/lib/libnspr4.so
	libnspr4.so (NSPR_4.1) =>	 (version not found)
	libpthread.so.1 =>	 /usr/lib/libpthread.so.1
	libdl.so.1 =>	 /usr/lib/libdl.so.1
	librt.so.1 =>	 /usr/lib/librt.so.1
	libgtk-1.2.so.0 =>	 /opt/gnome/lib/libgtk-1.2.so.0
	libgdk-1.2.so.0 =>	 /opt/gnome/lib/libgdk-1.2.so.0
	libgmodule-1.2.so.0 =>	 /opt/gnome/lib/libgmodule-1.2.so.0
	libglib-1.2.so.0 =>	 /opt/gnome/lib/libglib-1.2.so.0
	libXext.so.0 =>	 /usr/lib/libXext.so.0
	libX11.so.4 =>	 /usr/lib/libX11.so.4
	libsocket.so.1 =>	 /usr/lib/libsocket.so.1
	libnsl.so.1 =>	 /usr/lib/libnsl.so.1
	libm.so.1 =>	 /usr/lib/libm.so.1
	libCstd.so.1 =>	 /usr/lib/libCstd.so.1
	libCrun.so.1 =>	 /usr/lib/libCrun.so.1
	libw.so.1 =>	 /usr/lib/libw.so.1
	libthread.so.1 =>	 /usr/lib/libthread.so.1
	libc.so.1 =>	 /usr/lib/libc.so.1
	libaio.so.1 =>	 /usr/lib/libaio.so.1
	libdga.so.1 =>	 /usr/openwin/lib/libdga.so.1
	libmp.so.2 =>	 /usr/lib/libmp.so.2
	/usr/lib/cpu/sparcv8plus/libCstd_isa.so.1
	/usr/platform/SUNW,Sun-Blade-100/lib/libc_psr.so.1
sunws327: /home/tlabai/sfergus/projects/mozilla->cd ../mozilla_1.5
sunws327: /home/tlabai/sfergus/projects/mozilla_1.5->ldd mozilla-bin
	libmozjs.so =>	 /opt/gnome/lib/libmozjs.so
	libplds4.so =>	 /opt/gnome/lib/libplds4.so
	libplc4.so =>	 /opt/gnome/lib/libplc4.so
	libplc4.so (NSPR_4.0) =>	 (version not found)
	libnspr4.so =>	 /opt/gnome/lib/libnspr4.so
	libnspr4.so (NSPR_4.1) =>	 (version not found)
	libpthread.so.1 =>	 /usr/lib/libpthread.so.1
	libdl.so.1 =>	 /usr/lib/libdl.so.1
	librt.so.1 =>	 /usr/lib/librt.so.1
	libgtk-1.2.so.0 =>	 /opt/gnome/lib/libgtk-1.2.so.0
	libgdk-1.2.so.0 =>	 /opt/gnome/lib/libgdk-1.2.so.0
	libgmodule-1.2.so.0 =>	 /opt/gnome/lib/libgmodule-1.2.so.0
	libglib-1.2.so.0 =>	 /opt/gnome/lib/libglib-1.2.so.0
	libXext.so.0 =>	 /usr/lib/libXext.so.0
	libX11.so.4 =>	 /usr/lib/libX11.so.4
	libsocket.so.1 =>	 /usr/lib/libsocket.so.1
	libnsl.so.1 =>	 /usr/lib/libnsl.so.1
	libm.so.1 =>	 /usr/lib/libm.so.1
	libCrun.so.1 =>	 /usr/lib/libCrun.so.1
	libw.so.1 =>	 /usr/lib/libw.so.1
	libthread.so.1 =>	 /usr/lib/libthread.so.1
	libc.so.1 =>	 /usr/lib/libc.so.1
	libaio.so.1 =>	 /usr/lib/libaio.so.1
	libdga.so.1 =>	 /usr/openwin/lib/libdga.so.1
	libmp.so.2 =>	 /usr/lib/libmp.so.2
	/usr/platform/SUNW,Sun-Blade-100/lib/libc_psr.so.1
sunws327: /home/tlabai/sfergus/projects/mozilla_1.5->
(Reporter)

Comment 6

15 years ago
Hello,

Solaris 8, 1.6 for gtk2 installation works and I get no errors or crashing.

I have made no path updates, but going from 1.4 to this 1.6 version seems fine.
Not sure what was wrong with 1.5.

reject or close this...

SFII
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.