Closed Bug 223129 Opened 18 years ago Closed 15 years ago

make use of 'List-XXX' headers in mail to provide unsubscribe/help buttons in the gui

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 29041

People

(Reporter: lists, Assigned: mscott)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85.7 (KHTML, like Gecko) Safari/85.5
Build Identifier: new feature

most mailing list managers add a couple of extra mail header lines
like X-List
or List-Id
it would be nice to have a button so you could use the unsubscribe information provided to you in 
the email so you could click on it, and it would either go to the url or fill in the mailto details on 
how to unsubscribe.
you could even use the x-list/list-id field as a seperate column to display/sort on (as usually the 
to address might not be the list's email)

Reproducible: Always

Steps to Reproduce:
1. new feature
2.
3.
Actual Results:  
new feature

Expected Results:  
new feature
OS: MacOS X → All
Hardware: Macintosh → All
The mailing list header extension does this. This implements RFC 2369.
http://www.cweiske.de/misc_extensions.htm#mailinglistheader
*** Bug 284005 has been marked as a duplicate of this bug. ***
This is basically a dup of bug 29041 -- I'd mark it as such, but don't have rights.
The fact that this bug even exists is rather odd.  I've always thought Mozilla prided itself on standards (at least on the web browser side anyway).
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 29041
You need to log in before you can comment on or make changes to this bug.