Closed Bug 223131 Opened 17 years ago Closed 14 years ago

Need option to prevent 'connection to server timed out' pop-up dialog

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 123440

People

(Reporter: bugs_mozilla_2q1889, Assigned: Bienvenu)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

Well, when opening the mailnews client, I'm often not online. Therefore I don't
want to have to wait for that dialog to appear (get mails on startup activated).

Easiest solution: provide an option to disable all mailnews connection timed out
alert message windows.

Best solution (IMHO, maybe also for the browser interface): a status icon
displaying the status of the last connection attempt. Clicking on it would bring
up a log window with detailed descriptions. But I think that this enhancement
has been already submitted.

I hope that this (at least not the first part) is not a dupe, but I have done
several searches before submitting.

Reproducible: Always

Steps to Reproduce:
1. unplug your inter
2. start mailnews (with get mails on startup activated)
3. wait for the error message


Expected Results:  
Kill the error message. Don't "block" the user interface.
Please confirm. I too have been annoyed by the "connection timed out" dialog too
often. Although my gripe is a little different:

When MailNews is configured to check for new messages every X minutes, but the
window is minimized, I do not wish to see my MailNews taskbar button flashing to
inform me of the failure to contact the server; only when by my own decision I
switch to the MailNews window can I 'tolerate' such a pop-up dialog, and even
then I don't like it (usually what happens is that on the second attempt my mail
server does respond, so I'm getting notified of a transient problem).

Reporter: consider renmaming the bug to "need option to prevent 'connection to
server timed out' pop-up in some cases".
Component: Mail Window Front End → Preferences
Product: MailNews → Thunderbird
Summary: Option to disable initial "Connect to server ... failed" error message dialog → Need option to prevent 'connection to server timed out' pop-up dialog
Version: Trunk → unspecified
Attached patch simple solution (obsolete) — Splinter Review
How about, instead of not displaying the error message at all, displaying it in
in the status bar?
(In reply to comment #3)
> How about, instead of not displaying the error message at all, displaying it in
> in the status bar?

Do it. :-)

I already suggested that elsewhere: to show a general error log icon in the
status bar (like the icon for the popup blocker) of the browser. Clicking on it
should pop up some sort of error history.

Currently, I just don't know enough of mozilla's codebase to do that. I need
more time and I haven't any of it right now. Maybe we should create an
enhancement request for 'such a thing' and make this bug dependable on it.

Additionally, this patch does not work for IMAP accounts -- although it would be
quite easy to do that.
I'll add this one to my "hoping to get around to after my remaining exams" list...
Attachment #153243 - Attachment is obsolete: true
Attachment #153463 - Flags: review?(sspitzer)
Attachment #153463 - Flags: superreview?
over to david, as he's fought with offline before.

as far as adding pref ui to tbird, you'll have to talk to mscott about this.
Assignee: sspitzer → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Isn't this basically a dupe of bug 123440?
*** Bug 255360 has been marked as a duplicate of this bug. ***
*** Bug 287378 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 123440 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Comment on attachment 153463 [details] [diff] [review]
New preference to make Thunderbird quiet about NET_TIMEOUT_ERRORS

This patch is outdated (just applies to the old prefwindow code) and this bug has also been duplicated. If this is still an issue, please update the patch, post it to the appropriate bug and pick an appropriate reviewer from http://www.mozilla.org/projects/thunderbird/review.html
Attachment #153463 - Flags: superreview?
Attachment #153463 - Flags: review?(sspitzer)
You need to log in before you can comment on or make changes to this bug.