suggestion for additional window layout

RESOLVED DUPLICATE of bug 215661

Status

--
enhancement
RESOLVED DUPLICATE of bug 215661
15 years ago
3 years ago

People

(Reporter: mohr.42, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Build: Thunderbird 0.3

Someone on n.p.m.wishlist requested this layout for the TB main window:

+--------+------------+
|Folders |Preview Pane|
|        |            |
+--------+            |
|Message |            |
| List   |            |
+--------+------------+ 

Related:  bug 215661, bug 213945.  I'm not sure if this should be in the same
bug as bug 215661.
(Reporter)

Comment 1

15 years ago
Created attachment 133937 [details]
/chrome/messenger.jar/content/messenger/messenger.xul

Somebody on n.p.m.wishlist edited the attached file and managed to get this
layout.  I'm not sure of the quality of it, and I'm not sure where to diff it,
or if I should.  If you really want this layout, you can try replacing the
above file with the attached one, but make backups.

Comment 2

15 years ago
IIRC Thunderbird now uses dynamic configuration so changing the XUL around
shouldn't have much effect.

Comment 3

15 years ago
*** Bug 228093 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
*** Bug 227678 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

15 years ago
Proposed new look from one of the dupes:  <http://jyxo.cz/img/thunderidea.png>.

Comment 6

15 years ago
*** Bug 230977 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
I'd also like to see a different layout option - with the message list
full-width at the top and the folders and message preview split at the bottom,
such as:

+---------------+
| Message list  |
|               |
+-----+---------+
|Fldrs| Preview |
|     |         |
+-----+---------+

Even better would be a layout option similar to that of Microplanet Gravity
(Usenet client) where the layout can be chosen, and also the panes *within* the
layout can be chosen, so you can choose, for example, to have the three panes
vertically stacked, then choose which panes are which within the layout.

See http://www.steev.me.uk/~steven/window-layout.png for a screenshot which can
probably explain it better than me ;-)

Comment 8

14 years ago
(In reply to comment #7)
> I'd also like to see a different layout option - with the message list
> full-width at the top and the folders and message preview split at the bottom,

That's bug 215661 -- and a better suggestion than the one in this bug, I think.


> See http://www.steev.me.uk/~steven/window-layout.png for a screenshot

That's a nifty UI.  It doesn't have the 3-column layout that has been 
implemented, but that would be simple.

Comment 9

14 years ago
(In reply to comment #0)
> Build: Thunderbird 0.3
> 
> Someone on n.p.m.wishlist requested this layout for the TB main window:
> 
> +--------+------------+
> |Folders |Preview Pane|
> |        |            |
> +--------+            |
> |Message |            |
> | List   |            |
> +--------+------------+ 

I will add my wish for this layout. Messages are usually longer than wider (and
can wrap if too wide) and this layout allows more of the message to be
displayed. I currently use this layout in Mulberry, Agent and 40Tude Dialog. I
would like to switch to TB but am hooked on this layout.

Is it possible to hack the UI (XUL???) to create this view?

Comment 10

14 years ago
(In reply to comment #7)
> I'd also like to see a different layout option - with the message list
> full-width at the top and the folders and message preview split at the bottom,

Strongly agree, and posted my reasons </a
href="http://forums.mozillazine.org/viewtopic.php?t=246063&highlight=proposed+window+layout">here</a>
before finding this bug.

Updated

12 years ago
Duplicate of this bug: 371687
QA Contact: front-end

Comment 12

11 years ago
An extension that implements this view is available at mozdev.org
http://morelayoutsforthunderbird.mozdev.org/

The extension added this view as "Stacked" and includes fullscreen toggle like Fx.
Given this RFE has a working solution by use of the extension should it be closed or resolved by incorporation of the extensions code.

Comment 13

11 years ago
Well, the extension does only part of what I would like ( http://jyxo.cz/img/thunderidea.png )

The extension (its "Stacked" view) places the folder list above e-mail list (which is great), but still displays folders in a vertical list (which makes it unusable). If the folder list panel is wider than taller, than the logical conclusion is listing the folders in line.

Incorporating the extension's code is a good idea, but it should not end there.
Assignee: mscott → nobody

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 215661
You need to log in before you can comment on or make changes to this bug.