table cell (td) does not span columns when colspan is used along with style tag

RESOLVED INVALID

Status

()

Core
Layout: Tables
--
major
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: nate, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

In the page referenced above (www.n8guy.com/php/gallery/index3.php), I noticed
that table cells that are supposed to span multiple columns (using colspan) do
not do so if there is a CSS style tag.  In this case, the single cell should
span the total number of columns given.

Reproducible: Always

Steps to Reproduce:
1.  Open www.n8guy.com/php/gallery/index3.php
2.  See the cell only span one column, not the designated 9

Actual Results:  
I saw the cell only spanning one column, not the nine columns that it should
have spanned.

Expected Results:  
Written the engine to display cells as spanning the number of columns dictated
in the td tag when a specific style is also specified.

Comment 1

15 years ago
It's not because they've been styled per se.

It's because the style being applied include a float:right, most likely.  Just
take that out and the page looks fine.  I don't see why you would want to float it.
Yes.  Our behavior is correct.  'float: right' makes it no longer a table cell.
 See http://www.w3.org/TR/CSS21/visuren.html#dis-pos-flo .  Once that happens,
we construct an anonymous table cell around it, but that anonymous table cell
doesn't have a colspan.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.