Account Wizard's Outgoing Server is blank when adding second mail account

VERIFIED FIXED

Status

SeaMonkey
MailNews: Account Configuration
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 1999122100M12: NT4, Linux/Redhat 6.0, Mac 8.5.1

Overview: In a new profile create a mail account. Add a second mail account and
notice that the Account Wizard's "Outgoing (SMTP) Server" text box is blank.

Steps to recreate:
- Run "mozilla -installer" to create a new profile
- When the Account Wizard begins, create the first mail account (i.e. POP). Make
sure that the "Server Information" dialog has an entry for the "Outgoing (SMTP)
Server" (i.e. nsmail-2)
- After the Account Wizard creates the first mail account, it should be visible
in the folder pane. Note: Do not close Mail.
- Go to the Account Settings dialog, within the same mail session,
and add a second mail account.
- Advance through the Account Wizard until the "Server Information" dialog
appears.

Actual Results: Notice that the "Outgoing (SMTP) Server" text box is blank.

Expected Results: When adding the second mail account in the same session, the
Account Wizard should display the first mail account's SMTP Server name. You
shouldn't have to close and restart Mail.

Workaround:  Mail must be closed and reopened for the Account Wizard's "Server
Information" dialog to display the "Outgoing (SMTP) Server" name.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → nbaca
(Reporter)

Comment 1

18 years ago
Setting QA Contact to nbaca.
(Reporter)

Comment 2

18 years ago
Build 1999122109M13: NT4, Linux/Redhat 6.0, Mac 8.5.1
Regression in the M13 build.

In Account Wizard's "Server Information" dialog the Server Name in the "Outgoing
(SMTP) Server" area is always blank. For new profiles or migrated profiles.
(Assignee)

Comment 3

18 years ago
*** Bug 22949 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
fixed. init() was getting called too late
(Assignee)

Comment 5

18 years ago
*** Bug 23005 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
Build 2000010309M13: NT4, Linux/Redhat 6.0, Mac 8.5.1
Verified Fixed.

In the Account Wizard, the Server Name in the "Outgoing (SMTP) Server" area now
retains the server name with new profiles or migrated profiles.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.