size of toolbar buttons proportional to caption text width

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: Jerome Quelin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla Thunderbird 0.3 (20031013)

In the toolbar buttons of the main window (and the compose window also), the
button width is proportional to the caption text.
"Write" is small (5 letters)
"Address Book" is large (12 letters)

The previous version used to have a non-proportional size, which was:
1. nicer (for the eyes)
2. more usable (it's more difficult to hit a small "Write" button hidden between
two large buttons)

Reproducible: Always

Steps to Reproduce:
1. open thunderbird 3
2. view / toolbars / Mail Toolbar
3. move the mouse over the buttons to check their width
Actual Results:  
Each button is as width as its caption.

Expected Results:  
Every button should have the same width.
(Reporter)

Comment 1

14 years ago
When right-clucking on the toolbar | customize | show icons (instead of
icons+text), the toolbar buttons all share the same width, which should always
be the case imo.

Comment 2

14 years ago
While comment #1 shows the "Doctor, it hurts when I do this", "Then don't do
that" approach, it's actually fairly easy to fix this bug, and it would make the
UI look a lot more professional.

Also, isn't icons+text the default?  So shouldn't it look good?

The file involved with the main toolbar in the theme is
chrome/qute.jar:skin/classic/messenger/primaryToolbar.css

It should be as simple as adding 'min-width' tags to .toolbar-button-1[mode="full"]
Giving min-width in terms of 'ex' units would make button width proportional to
whichever font is the default.

There's a similar bug showing progress for firefox: bug 232550

I'm not an advanced css-coder, but I will try to look into this.

Comment 3

14 years ago
I apologize for this not being a proper patch, but I thought I'd get this out
here because it's simple.

I put the following in my userChrome.css to get minimum width buttons, but only
if text is showing on a button (icons-only mode is unaffected.)

8.0ex is about right so that most buttons are the same width.  "Address Book" is
longer, but I didn't want to make all of the buttons THAT wide.
---------------------
/* minimum width stuff */
toolbar[mode="full"] .toolbarbutton-1,
toolbar[mode="text"] .toolbarbutton-1 {
  min-width: 8.0ex !important;
}

toolbar[mode="full"] .toolbarbutton-menubutton-button,
toolbar[mode="text"] .toolbarbutton-menubutton-button {
  min-width: 8.0ex !important;
}

Comment 4

14 years ago
I wonder if "Address Book" could be changed to "Addresses" or "Contacts" in
order to make it not such big button?

Comment 5

13 years ago
see bug 232550

Comment 6

13 years ago
*** Bug 243323 has been marked as a duplicate of this bug. ***
QA Contact: front-end

Updated

9 years ago
Assignee: mscott → nobody

Comment 7

8 years ago
wontfix or WFM?  (or otherwise obsolete)
I don't know that we have proportional buttons unless the text is inside the button.
Seems like a million years ago, though it was actually only in the 2.0 theme updates.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.