DNS: IPv6: Camino builds after 09-17-2003 are loading images slow.

RESOLVED DUPLICATE of bug 231118

Status

Camino Graveyard
General
--
major
RESOLVED DUPLICATE of bug 231118
15 years ago
15 years ago

People

(Reporter: Jasper, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030818 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030818 Camino/0.7+

Right after the 20030818 NB camino started to have image loading performance
issues. Images load but take longer that normal.

Reproducible: Always

Steps to Reproduce:
1. First go to www.apple.com with the 20030818 NB
2. Then go there again with a more recent nightly build.

Actual Results:  
Camino is waiting longer for images to load properly in more recent nightly buidls.

Expected Results:  
Camino should load images as fast as the 20030818 NB or Mozilla 1.5.
(Reporter)

Comment 1

15 years ago
Perhaps due to these Bugs?
205893 209079 73642
(Reporter)

Comment 2

15 years ago
I pinned down the exact time frame when the issue started to suface:
between 2003-09-17-02 (ok) build and the 2003-10-02-11 (broken) build.
(Assignee)

Updated

15 years ago
Summary: Camino builds after 08-18-2003 are loading images slow. → Camino builds after 09-17-2003 are loading images slow.
I am reasonably sure this problem wasn't in the 9/26 build I had.  That narrows
it down somewhat.

Checking bonsai, there were a bunch of IO/threading/stream listener changes made
10/5.  Very tempting . . . but apparently not the right bugs.

The next best guesses I can come up with are bug 187899, bug 218837 (although
thi s one was apparently backed out), and bug 211462 - a Mac specific bug
dealing with graphics . . . but it seems very odd that it would screw things up.
(Reporter)

Comment 4

15 years ago
Yesterday I noticed something.

If I ran the post 1002 Camino for a while and then switched to the 0917 version.
The 0917 version would have some of the troubles too. The way to fix it was to
clear cach and everything worked again. No this didn't help for the 1002 build.

So I think there is a cache issue involved here.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
some things to check:
- reverse the order in your steps to reproduce
- clear cache every time between launches when comparing
- check mozilla builds from the same time periods. do they have the same problem?
(Reporter)

Comment 6

15 years ago
It seems that the Camino 20031030 NB doesn't have these issues anymore.
Mike, any idea what happend?
(Reporter)

Comment 7

15 years ago
WFM ?
Created attachment 134877 [details]
network stack log

No, the bug is still there.  It turns up reliably for me at
http://www.daytondailynews.com.  I grabbed a network log, but I don't think the
problem is in the network.  The page source (already downloaded) shows lots of
content which just isn't appearing on the screen.
(Reporter)

Comment 9

15 years ago
How odd. Let's say that the issue is now less obvious but is indeed still there.
Especially the website mentioned in Comment #8 shows the big difference between
the latest nightly builds and the pre oktober builds.

Comment 10

15 years ago
is this the same thing? (compare to safari)

http://www.scifi.com/farscape/characters/zhaan.html
A poster in the Mozillazine forum comes up huge.  Looks like its an IPv6
hostname lookup bug in 10.2 which was fixed in 10.3.  

*** This bug has been marked as a duplicate of 219512 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 12

15 years ago
REOPEN:
There have been several changes that affect Mac OS in this area recently, so I'd
like to hook this up as a depends, since I don't keep up on Camino.

What I'm most concerned with is if this problem happens in 10.2 (probably should
not anymore) and 10.3 (probably should still happen), in current builds (aka 2004).
Status: RESOLVED → REOPENED
QA Contact: benc
Resolution: DUPLICATE → ---
Summary: Camino builds after 09-17-2003 are loading images slow. → DNS: IPv6: Camino builds after 09-17-2003 are loading images slow.
(Assignee)

Comment 13

15 years ago

*** This bug has been marked as a duplicate of 231118 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.