mozilla simply quits on certain pages

RESOLVED DUPLICATE of bug 183729

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 183729
15 years ago
15 years ago

People

(Reporter: Ad Timmering, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: mozilla/1.4-r3 gentoo-ebuild

Mozilla (and Epiphany etc) simply exit when I visit for example Japanese Google 
page (also certain other pages).

Reproducible: Always

Steps to Reproduce:
1.Open Mozilla, Epiphany, ..
2.Enter URL in address bar: www.google.co.jp

Actual Results:  
Mozilla quits, no error. If epiphany, segfault.



Here is a bugbuddy report on Epiphany but I think it also shows the trace on 
mozilla. 

My installation is a Gentoo 1.4 (i686). Problems was with Mozilla 1.4-r3 (and 
Epiphany 1.0) but persists with Mozilla 1.5/Epiphany 1.0.3.

Distribution: Unknown
Package: epiphany
Severity: normal
Version: GNOME2.4.0 unspecified
Gnome-Distributor: Gentoo Linux
Synopsis: epiphany gives segfault browsing certain pages
Bugzilla-Product: epiphany
Bugzilla-Component: Mozilla interaction
Bugzilla-Version: unspecified
BugBuddy-GnomeVersion: 2.0 (2.4.0.1)
Description:
Description of the crash:
On opening certain pages (seems to be Japanese pages in my case)
Epiphany segfaults

Steps to reproduce the crash:
1. Start Epiphany (opens on english google in my case)
2. Location to http://www.google.co.jp/
3. SegFault-> Bug-Buddy opens

How often does this happen?
Every time.

Additional Information:
epiphany-1.0 / mozilla 1.4-r3 on gentoo


Debugging Information:

Backtrace was generated from '/usr/bin/epiphany-bin'

(no debugging symbols found)...(no debugging symbols found)...[New
Thread 16384 (LWP 20652)]
[New Thread 32769 (LWP 20655)]
[New Thread 16386 (LWP 20656)]
[New Thread 32771 (LWP 20657)]
[New Thread 49156 (LWP 20658)]
[New Thread 81925 (LWP 20660)]

0x40c4a20a in waitpid () from /lib/libpthread.so.0
#0  0x40c4a20a in waitpid () from /lib/libpthread.so.0
#1  0x40359e68 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#2  0x40105482 in nsProfileLock::FatalSignalHandler(int) ()
   from /usr/lib/mozilla/libgtkembedmoz.so
#3  0x40c4903c in __pthread_sighandler () from /lib/libpthread.so.0
#4  <signal handler called>
#5  0x40fcba19 in XftCharIndex () from /usr/X11R6/lib/libXft.so.2
#6  0x40fc734e in XftTextExtents32 () from /usr/X11R6/lib/libXft.so.2
#7  0x420d518a in nsFontXft::GetWidth32(unsigned) ()
   from /usr/lib/mozilla/components/libgfx_gtk.so
#8  0x420d4626 in nsFontMetricsXft::TextDimensionsCallback(unsigned,
nsFontXft*, void*) () from /usr/lib/mozilla/components/libgfx_gtk.so
#9  0x420d5dd3 in nsFontXft::GetMaxDescent() ()
   from /usr/lib/mozilla/components/libgfx_gtk.so
#10 0x420d4212 in nsFontMetricsXft::EnumerateGlyphs(unsigned*, unsigned,
void (*)(unsigned, nsFontXft*, void*), void*) ()
   from /usr/lib/mozilla/components/libgfx_gtk.so
#11 0x420d23c2 in nsFontMetricsXft::GetTextDimensions(unsigned short
const*, unsigned, nsTextDimensions&, int*, nsRenderingContextGTK*) ()
   from /usr/lib/mozilla/components/libgfx_gtk.so
#12 0x420bb357 in nsRenderingContextGTK::GetTextDimensions(unsigned
short const*, unsigned, nsTextDimensions&, int*) ()
   from /usr/lib/mozilla/components/libgfx_gtk.so
#13 0x414e5a0a in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#14 0x414e656f in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#15 0x414b411f in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#16 0x414afc5a in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#17 0x414af836 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#18 0x414af61c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#19 0x414b411f in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#20 0x414afc5a in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#21 0x414af836 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#22 0x414af61c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#23 0x414b411f in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#24 0x4147e1e5 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#25 0x4147df0f in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#26 0x4147dcb4 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#27 0x4147db1f in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#28 0x4147bf27 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#29 0x4147bc98 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#30 0x41479d93 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#31 0x4148a54c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#32 0x41551810 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#33 0x4148a54c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#34 0x4156d9a7 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#35 0x4156e8db in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#36 0x4148a54c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#37 0x4156fdc5 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#38 0x4157203d in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#39 0x4148a54c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#40 0x4155b889 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#41 0x41558e07 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#42 0x4148a54c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#43 0x415687ff in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#44 0x4156ad3d in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#45 0x41483031 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#46 0x4147d3ab in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#47 0x4147c210 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#48 0x4147bc98 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#49 0x41479d93 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#50 0x41483031 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#51 0x4147d3ab in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#52 0x4147c210 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#53 0x4147bc98 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#54 0x41479d93 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#55 0x41483031 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#56 0x4147d3ab in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#57 0x4147c210 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#58 0x4147bc98 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#59 0x41479d93 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#60 0x4148a54c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#61 0x4149fb09 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#62 0x41581332 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#63 0x41580f4a in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#64 0x41578740 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#65 0x415746a6 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#66 0x41578740 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#67 0x41582ecc in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#68 0x4149bc2d in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#69 0x4149bf68 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#70 0x4149bc8b in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#71 0x41578740 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#72 0x4157bbcb in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#73 0x4149acee in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#74 0x4148a54c in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#75 0x414eadc3 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#76 0x414c784d in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#77 0x414d5b28 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#78 0x414d6e62 in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#79 0x414d564f in NSGetModule ()
   from /usr/lib/mozilla/components/libgklayout.so
#80 0x401aa867 in PL_HandleEvent () from /usr/lib/mozilla/libxpcom.so
#81 0x401aa774 in PL_ProcessPendingEvents () from
/usr/lib/mozilla/libxpcom.so
#82 0x401abb7b in nsEventQueueImpl::ProcessPendingEvents() ()
   from /usr/lib/mozilla/libxpcom.so
#83 0x41e6a715 in NS_GetSpecialDirectory(char const*, nsIFile**) ()
   from /usr/lib/mozilla/components/libwidget_gtk2.so
#84 0x40dab4ed in g_io_unix_dispatch () from /usr/lib/libglib-2.0.so.0
#85 0x40d88180 in g_main_dispatch () from /usr/lib/libglib-2.0.so.0
#86 0x40d86518 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#87 0x40d8864b in g_main_context_iterate () from
/usr/lib/libglib-2.0.so.0
#88 0x40d86b0f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#89 0x4099c3c8 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#90 0x0807567d in main ()
#91 0x40e087a7 in __libc_start_main () from /lib/libc.so.6

Thread 6 (Thread 81925 (LWP 20660)):
#0  0x40e1bf68 in sigsuspend () from /lib/libc.so.6
No symbol table info available.
#1  0x40c46238 in __pthread_wait_for_restart_signal ()
   from /lib/libpthread.so.0
No symbol table info available.
#2  0x40c42ceb in pthread_cond_wait@GLIBC_2.0 () from
/lib/libpthread.so.0
No symbol table info available.
#3  0x4021fa2f in PR_WaitCondVar () from /usr/lib/mozilla/libnspr4.so
No symbol table info available.
#4  0x401ae690 in nsThreadPool::GetRequest(nsIThread*) ()
   from /usr/lib/mozilla/libxpcom.so
No symbol table info available.
#5  0x401aef92 in nsThreadPoolRunnable::Run() ()
   from /usr/lib/mozilla/libxpcom.so
No symbol table info available.
#6  0x401ad5db in nsThread::Main(void*) () from
/usr/lib/mozilla/libxpcom.so
No symbol table info available.
#7  0x40225269 in PR_Select () from /usr/lib/mozilla/libnspr4.so
No symbol table info available.
#8  0x40c43d40 in pthread_start_thread () from /lib/libpthread.so.0
No symbol table info available.

Thread 5 (Thread 49156 (LWP 20658)):
#0  0x40c49a46 in nanosleep () from /lib/libpthread.so.0
No symbol table info available.
#1  0x00000001 in ?? ()
No symbol table info available.
#2  0x40c42ec9 in pthread_cond_timedwait_relative () from
/lib/libpthread.so.0
No symbol table info available.
#3  0x4021f7ba in PR_Unlock () from /usr/lib/mozilla/libnspr4.so
No symbol table info available.
#4  0x4021f9ae in PR_WaitCondVar () from /usr/lib/mozilla/libnspr4.so
No symbol table info available.
#5  0x401b1351 in TimerThread::Run() () from
/usr/lib/mozilla/libxpcom.so
No symbol table info available.
#6  0x401ad5db in nsThread::Main(void*) () from
/usr/lib/mozilla/libxpcom.so
No symbol table info available.
#7  0x40225269 in PR_Select () from /usr/lib/mozilla/libnspr4.so
No symbol table info available.
#8  0x40c43d40 in pthread_start_thread () from /lib/libpthread.so.0
No symbol table info available.
(Reporter)

Updated

15 years ago
Component: Browser-General → Layout

Comment 1

15 years ago
See also bug 203350 comment 14

*** This bug has been marked as a duplicate of 193276 ***
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

15 years ago
Bug 223224 was marked as dup- but I found out the problem for that one:
I had two ttf (msgothic and msmincho) files in
/usr/X11R6/lib/X11/fonts/truetype/ that were 400 and owned by root (placed them
there myself, stupid mistake not to change to 644). Still, opening a Japanese
page with these two Japanese ttf's in the directory caused Mozilla to quit.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

15 years ago
So, just to make sure (sorry for second entry), the original problem was solved
in my case by changing permission on these two files.

Comment 5

15 years ago
comment 4 definitely shows this is bug 183729.

*** This bug has been marked as a duplicate of 183729 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Keywords: crash
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.