application's menu bar doesn't look like a native menu bar

VERIFIED INVALID

Status

()

VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: vova, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031021 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031021 Firebird/0.7+

Firebird's menu bar does not look like menu bar of all other native Gnome
applications. It seems that menu bar picks color theme up but general appearance
is far from native.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Menu bar should look like native Gnome menu bar

Comment 1

15 years ago
Not a bug. Firebird uses a cross-platform toolkit to display the UI, which uses
some but not all native widgets.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
QA Contact: bugzilla
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
What does it mean "not a bug". I'm a user and I don't know what Firebird uses
inside. But I want that my desktop looks an feels consisten. Now it's not true.
If your cross platform toolkit mixes together native and non native widgets so
not native widgets should looks like native. Take a look at Swing (Java cross
platform toolkit) under Windows XP. It looks like native!

Comment 3

15 years ago
The interface is as native as it can be.
Nothing more can be done. Sorry but that's the end of it. Use a theme which
tries to imitate gnome app appearance.
(Reporter)

Comment 4

15 years ago
So as I understand you are not going to fix this even in a future? If so "not  
a bug" is a nice solution to ping-pong user requests :( Who said that current
implementation is "native as it can be"? If there are limitations in _current_
implementation it doesn't mean that it cannot be fixed (improved) in the
future... So I insist that that is a bug. Moreover menu under Windows XP looks
like native! It simply means that GTK port lacks some functionality. And that is
a bug.

Updated

13 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.