XML embeded in a textarea loses proper capitalization for tags called "Address".

RESOLVED DUPLICATE of bug 64799

Status

()

Core
HTML: Parser
--
minor
RESOLVED DUPLICATE of bug 64799
14 years ago
14 years ago

People

(Reporter: Scott, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

We are embedding XML into a textarea for a test application we are developing. 
Under mozilla and firebird, the "Address close tag" </Address> is rendered with
incorrect capitaliztion </address>

Under Internet Explorer it displays as expected.  Please see the enclosed HTML
markup for an example. (Put it into a file calleed something.html, and open it
using Mozilla or firebird)

Thanks,

Scott




<html>
<head><title>Test your cxml.</title></head>
<body>

<h1>Please enter your cXML and click test.</h1>
<h2>Session Setup Request</h1>
<form action="setupRequest.do" method="POST">
   <textarea name="data" cols="100" rows="20" wrap="physical">
<?xml version="1.0"?>
<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.007/cXML.dtd">
<cXML version="1.0" payloadID="2003-10-02T13:18:12-07:00"
timestamp="2003-10-02T13:18:12-07:00">

	<Header>
		<From>
			<Credential domain="NetworkId">
				<Identity>xxxx</Identity>
			</Credential>
		</From>
		<To>
			<Credential domain="">

				<Identity/>
			</Credential>
		</To>
		<Sender>
			<Credential domain="NetworkId">
				<Identity>xxxx</Identity>
				<SharedSecret>test</SharedSecret>
			</Credential>

			<UserAgent>xxxx</UserAgent>
		</Sender>
	</Header>
	<Request>
		<PunchOutSetupRequest operation="create">
			<BuyerCookie>PSFT_2003-10-02T13:18:12-07:00</BuyerCookie>
			<BrowserFormPost>
			
<URL>https://xxx.xxxxx.com:8385/psc/tfstfa/EMPLOYEE/ERP/c/PV_MAIN_MENU.PV_CXML_POOM.GBL?Page=PV_CXML_POOM&amp;amp;MERCHANTID=XXXXX</URL>

			</BrowserFormPost>
			<SupplierSetup>
				<URL>https://xxx.xxxx.xxxx/xxx/xxx/ccdas/b2b/setupRequest_do.prx</URL>
			</SupplierSetup>
			<ShipTo>
				<Address>
					<Name xml:lang="en"/>
					<PostalAddress name="Columbus">

						<DeliverTo>Tester,Testie</DeliverTo>
						<Street>xyz company</Street>
                        <Street>xyz street</Street>
						<City>xyz city</City>
						<State>XX</State>
						<PostalCode>31909</PostalCode>

						<Country isoCountryCode="USA"/>
					</PostalAddress>
				</Address>
			</ShipTo>
		</PunchOutSetupRequest>
	</Request>
</cXML>


   </textarea>

   <br>
   <input type="submit">
</form>

<br>

<h2>Approve PO</h1>
<form action="approveRequisition.do" method="POST">
   <textarea name="data" cols="100" rows="20" wrap="physical">
<?xml version="1.0"?>
<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.1.007/cXML.dtd">
<cXML version="1" payloadID="2003-10-02T13:25:05-07:00"
timestamp="2003-10-02T13:25:05-07:00">
	<Header>

		<From>
			<Credential domain="NetworkId">
				<Identity>XXXXX</Identity>
			</Credential>
		</From>
		<To>
			<Credential domain="">
				<Identity/>

			</Credential>
		</To>
		<Sender>
			<Credential domain="NetworkId">
				<Identity>XXXXX</Identity>
				<SharedSecret>XXXX</SharedSecret>
			</Credential>
			<UserAgent>XXXX</UserAgent>

		</Sender>
	</Header>
	<Request deploymentMode="production">
		<OrderRequest>
			<OrderRequestHeader type="new" orderID="RS001_0500000554" orderDate="2003-10-02">
				<Total>
					<Money currency="USD"/>
				</Total>
				<ShipTo>

					<Address addressID="0030200000">
						<PostalAddress name="default">
							<DeliverTo>XXXXX</DeliverTo>
							<Street>xxxxxx</Street>
							<Street>xxxxx</Street>
							<City>xxxxx</City>
							<State>XX</State>

							<PostalCode>31909</PostalCode>
							<Country isoCountryCode="US">USA</Country>
						</PostalAddress>
						<Email name="main">xxxx@xxxxx.xxxm</Email>
						<Phone>
							<TelephoneNumber>
								<CountryCode isoCountryCode="US">USA</CountryCode>

								<AreaOrCityCode/>
								<Number/>
							</TelephoneNumber>
						</Phone>
						<Name xml:lang="en">XXXX</Name>
					</address>
				</ShipTo>
				<BillTo>

					<address addressID="0091500821">
						<PostalAddress name="Corporate Headquarters A-1">
							<DeliverTo>XXXXe</DeliverTo>
							<Street>XXXs</Street>
							<Street>OXXXX</Street>
							<City>XXX</City>
							<State>XX</State>

							<PostalCode>61710</PostalCode>
							<Country isoCountryCode="US">USA</Country>
						</PostalAddress>
						<Name xml:lang="en">Replacement Service</Name>
					</address>
				</BillTo>
				<Shipping>

					<Money currency="USD">0</Money>
					<Description xml:lang="en-US">XXXXX</Description>
				</Shipping>
				<Contact role="Requestor">
					<Name xml:lang="en">XXX,XXX</Name>
					<Email>XXXXX@XXXX.XXX</Email>
				</Contact>

				<Contact role="Buyer">
					<Name xml:lang="en">XXXX,XXr</Name>
					<Email>XXXXX@XXXXXX.XXX</Email>
				</Contact>
				<Comments/>
			</OrderRequestHeader>
			<ItemOut quantity="2" requestedDeliveryDate="2003-10-02">
				<ItemID>

					<SupplierPartID>075603</SupplierPartID>
					<SupplierPartAuxiliaryID>XXXX</SupplierPartAuxiliaryID>
				</ItemID>
				<ItemDetail>
					<UnitPrice>
						<Money currency="USD">9.99</Money>
					</UnitPrice>

					<Description xml:lang="en">XXXXXX2</Description>
					<Classification domain=""/>
					<ManufacturerPartID/>
					<ManufacturerName/>
					<URL/>
					<Extrinsic name="POLineSched">1:1</Extrinsic>
					<UnitOfMeasure>EA</UnitOfMeasure>

				</ItemDetail>
				<Comments/>
			</ItemOut>
		</OrderRequest>
	</Request>
</cXML>

   </textarea>
   <br>
   <input type="submit">

</form>    


</body>
</html>


Reproducible: Always

Steps to Reproduce:
1.  Please
2.  see
3.  the
4.  above....

Actual Results:  
<Address>asdfasfasd</Address>

is displayed as
<Address>asdfasfasd</address>

Expected Results:  
<Address>asdfasfasd</Address>

should be displayed as

<Address>asdfasfasd</Address>
> We are embedding XML into a textarea 

Then you need to replace < and > with &lt; and &gt; since textarea contents are
in fact parsed by the HTML parser..... as HTML.

*** This bug has been marked as a duplicate of 64799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.