I enter "engineering", hit search, and get "yp.yahoo.com&qtx=engineering could not be found. Please check the name and try again." Other search terms seem to work; works in IE.

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: beckman, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I have a smart bookmark for Yahoo! Yellow pages:
http://yp.yahoo.com/py/ypResults.py?stx=%s&stp=a&tab=B2C&addr=100+Pitt+Street&city=Alexandria&state=VA&zip=22314&country=us&msa=8840&slt=38.804963&sln=-77.044935&cs=9&Submit=Search
Keyword: yp

This doesn't seem to cause the problem.  If I go to http://yp.yahoo.com/ and
type in engineering, I get an infobox saying:
   "yp.yahoo.com&qtx=engineering could not be found.  Please check the name and
try again."

I went to IE and tried it, and the term "engineering" worked fine.  It may be a
Yahoo! coding issue, or maybe a bug in the code that handles the related HTML. 
Too bad IE uses non-standard ways of making stupid code work.

Reproducible: Always

Steps to Reproduce:
1. Go to http://yp.yahoo.com/
2. Search for "engineering"
3. Hit "Search" button.

Actual Results:  
I got an infobox popup saying:

  "yp.yahoo.com&qtx=engineering could not be found.  Please check the name and
try again."


Expected Results:  
Submitted the search.

Tested in IE, works.  It worked on Win2000 at home; it may be a sporatic failure.
(Reporter)

Comment 1

15 years ago
Created attachment 133876 [details]
Screenshot of Firebird giving me the error
(Reporter)

Comment 2

15 years ago
Created attachment 133877 [details]
HTML code of the front page of Yahoo! Yellow Pages

Updated

15 years ago
Summary: I enter "engineering", hit search, and get "yp.yahoo.com&qtx=engineering could not be found. Please check the name and try again." Other search terms seem to work; works in IE. → I enter "engineering", hit search, and get "yp.yahoo.com&qtx=engineering could not be found. Please check the name and try again." Other search terms seem to work; works in IE.

Comment 3

15 years ago
I cannot reproduce in the same manner. I can only see this bug if I follow the
bookmark link (encapsulating previous search?), not if I go directly to
http://yp.yahoo.com Setting URL field accordingly.

I managed to reproduce this bug in mozilla, and then konqueror (=yuck), and even
lynx, so I'm confident it's not our bug! The fact that it works in IE and on
other machine is probably due to the fact that you load yp.yahoo.com directly on
those machines, but that other URL on your XP machine.

I could be off the mark, if so please comment further, otherwise this bug should
be resolved INVALID.


OFF TOPIC: This is one weird bug, any other search string works, including
engineerin or engineerink... I have no idea what could be happening, I'm glad
it's not a mozilla bug.
(Reporter)

Comment 4

15 years ago
Confirmed that the problem seems to be browser independent; I will look into it.
 Since it is browser independent, bug is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.