[dogfood][regression] The second time you close a msg compose window crash the app

VERIFIED FIXED in M13

Status

P3
blocker
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Assignee)

Description

19 years ago
I get this crash with debug build from today either on Mac or Windows

steps:
1) Start Mozilla
2) Start Messenger
3) Click "New Msg"
4) Close the compose window (click in close box)
5) Click "New Msg"
6) Close the compose window (click in close box)
7) --> crash in nsMsgCompose::~nsMsgCompose because m_editor has been already
destroyed.

So far, I found that the first time you open a compose window and then close it,
we are missing a release on nsMsgCompose therefore the destructor is never
called. Also we set twice the editor (nsMsgCompose:SetEditor !! to be verified).
The second time the object his correctly destroyed but for some reason editor is
destroyed before nsMsgCompose which try to unregister a document state listener
in editor which cause the crash.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: [dogfood][regression] The second time you close a msg compose window crash the app → [dogfood][regression] The second time you close a msg compose window crash the app
Target Milestone: M13
(Assignee)

Comment 1

19 years ago
correction, the editor is set correctly only once.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 2

19 years ago
Marking PDT+
(Assignee)

Updated

19 years ago
Whiteboard: [PDT+] → [PDT+] 12/23, I've already a fix for the crash part but not for the leak.
(Assignee)

Comment 3

19 years ago
I have a fix for the crash but I still not understand why we are leaking the
first time.
(Assignee)

Updated

19 years ago
Whiteboard: [PDT+] 12/23, I've already a fix for the crash part but not for the leak. → [PDT+] 12/23, need a code review...
(Assignee)

Comment 4

19 years ago
Ok, The leak is see the first time you close the window is due to the well knonw bug 21056.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] 12/23, need a code review... → [PDT+]
(Assignee)

Comment 5

19 years ago
Crash fixed and checked in.

Updated

19 years ago
QA Contact: lchiang → fenella

Comment 6

19 years ago
fenella - can you verify? Thanks.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
Linux Redhat 6.0 (2000-01-04-08 M13)
Win_nt 4.0 (2000-01-04-08 M13)
Mac (2000-01-04-08 M13)
This problem has been fixed.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.