Bookmarks manager and selecting new Personal Toolbar doesn't work

VERIFIED DUPLICATE of bug 205739

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 205739
14 years ago
11 years ago

People

(Reporter: whimboo, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When i wants to assign a new folder as PT inside the bookmarks manager it
doesn't work. The old folder is always shown again within the PT.

Reproducible: Always

Steps to Reproduce:
1. Select new folder within the bookmarks manager
2. Click "Set as Bookmarks Toolbar Folder" 
Actual Results:  
After the click the new folder isn't assigned and i get following entries within
the location column of bookmarks manager:

Old Folder             rdf:#$zV4r53
New Folder             NC:PersonalToolbarFolder

Additionally the rechanging to the old folder isn't available - menu entry is
grayed out.

Expected Results:  
The new selected folder should replace the old one inside the PT.

I found out that the entries inside the bookmarks.html aren't updated correctly.

I expect following behavior:
Changing the PT should move the attributes PERSONAL_TOOLBAR_FOLDER="true" and
ID="NC:PersonalToolbarFolder" to the new folder. The old one get an new
ID-Attribute.

Actually behavior:
Both attributes stay within the old folder and aren't moved. After i manually
move the attributes and restart Firebird my new PT is shown.
reporter, if you try a current nightly, what happens? this code has been
recently rewritten so this should work without issues
(Reporter)

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20031025
Firebird/0.7+

You are right. The actual nighly build shows right behavior. So we can mark this
bug as fixed. But some informations for me because i'm interested. Does the
rewrite starts before the FB 0.7 release or within the 0.7+ trunk? 

In my opinion it's bad that this bug damages the bookmark manager of FB 0.7. 
its actually a longstanding bug, I wanted to make sure you were talking about
the same issue before duping it though.

*** This bug has been marked as a duplicate of 205739 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
verified.
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.