when committing a bug, a error occured in carp.pm

RESOLVED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: maktub.zhu, Assigned: justdave)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 

every time i commit a bug, the following error message appers:
undef error - SELECT 
assigned_to,bug_file_loc,bug_severity,bug_status,cclist_accessible,
component,everconfirmed,groupset,keywords,op_sys,priority,product,qa_contact,rep
_platform,
reporter,reporter_accessible,resolution,short_desc,status_whiteboard,target_mile
stone,
version,votes, lastdiffed, now() FROM bugs WHERE bug_id = : You have an error 
in your SQL 
syntax. Check the manual that corresponds to your MySQL server version for the 
right syntax
 to use near '' at line 1 at C:/Perl/lib/CGI/Carp.pm line 312. 

Reproducible: Always

Steps to Reproduce:
1.commit a new bug
2.
3.

Actual Results:  
undef error - SELECT 
assigned_to,bug_file_loc,bug_severity,bug_status,cclist_accessible,
component,everconfirmed,groupset,keywords,op_sys,priority,product,qa_contact,rep
_platform,
reporter,reporter_accessible,resolution,short_desc,status_whiteboard,target_mile
stone,
version,votes, lastdiffed, now() FROM bugs WHERE bug_id = : You have an error 
in your SQL 
syntax. Check the manual that corresponds to your MySQL server version for the 
right syntax
 to use near '' at line 1 at C:/Perl/lib/CGI/Carp.pm line 312. 

Expected Results:  
no error

i use bugzilla 2.613tcl on win2000 with active perl
What version are you using?  There is no version with the number you reported. 
I suspect a typo.
(Reporter)

Comment 2

14 years ago
As I mentioned: i use bugzilla 2.613tcl on win2000 with active perl.
There is no version with that number distributed by us.  I can't even come up
with an existing Bugzilla version that might be based on without rearranging the
order of the digits.  Where did you get it from?
maktub.zhu@emc.com.tw (maktub.zhu), we need more information about this bug or
we will have to close it, because there's nothing we can do.
(In reply to comment #4)
> maktub.zhu@emc.com.tw (maktub.zhu), we need more information about this bug or
> we will have to close it, because there's nothing we can do.

No response from reporter. -> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.