If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Expose UI on OS X for tab navigation behaviour

VERIFIED DUPLICATE of bug 187508

Status

()

Firefox
Preferences
VERIFIED DUPLICATE of bug 187508
14 years ago
11 years ago

People

(Reporter: Philip Pawley, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Keyboard tabbing with Mozilla is excellent even in MacOS X but with Firebird it
works fine in Windows 98 but not is restricted to form fields in MacOS X. I
tried on http://www.alexanderworks.org.uk and here in bugzilla too. (It also
just skipped the drop-down menu).

Reproducible: Always

Steps to Reproduce:
1. Press tab a few times.
2. 
3.

Actual Results:  
The focus remains stuck in the form.

Expected Results:  
Focus should have moved through the hyperlinks as well as the form fields (it
does in Mozilla and Firebird for Windows 98 but not Firebird for MacOS X).

This behaviour can be altered in Mozilla preferences but not in Firebird's
prefences.
(Reporter)

Comment 1

14 years ago
Suggesting "Preferences" might be the correct component.
Component: General → Preferences

Comment 2

14 years ago
i think this may be deliberate.  i have the suspicion it may be a mac os user
interface guideline thing.

tabbing does not include links in mac firebird, mozilla, or safari.  it does
include links in mac ie.

in any case, this is a pref that can be set in about:config, see bug 140612.

leaning towards invalid.
(Reporter)

Comment 3

14 years ago
On reflection, after reading the bug 140612 comments, the behaviour does seem to
be deliberate. 

You were right that the default for Mozilla on MacOS is not to tab links. I had
forgotten that as I have always re-set it in preferences. That's fine for
Mozilla but, for Firebird, relegating this option to about:config is no use to
the average user who needs keyboard navigation. I'm not a programmer buit I'm
not an average user either. I'm at home in Windows, Linux and MacOS but I don't
know how to access about:config. I could learn, but how would that help other users?

A lot of users find using a mouse a very painful experience, so the ability to
navigate using the keyboard is very, very important. It is a major accessibility
issue. In any case, why waste a functionality that has been so brilliantly
implemented in Mozilla? All that is required is the ability to set this option
in Preferences in Firebird as well as in Mozilla.

Make sense?

Comment 4

14 years ago
yeah, i can understand wanting to expose more prefs to the user, but at the same
time i agree with the devs that the mozilla prefs dialog was an absolute
nightmare of bloat.  someone else can decide what to do with this.
This probably could find a place in the Advanced section of Options, for Mac
only, obviously.
Assignee: blake → bugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: mpconnor
Summary: Tabbing doesn't move the keyboard focus through the hyperlinks on a page → Expose UI on OS X for tab navigation behaviour

Comment 6

14 years ago
*** Bug 226690 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 233083 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
"i think this may be deliberate.  i have the suspicion it may be a mac os user
interface guideline thing.

tabbing does not include links in mac firebird, mozilla, or safari.  it does
include links in mac ie."

i don't know if this is a new thing, because i just started trying out safari 1.2 on tuesday, but safari 
does now offer this option.

under preferences, advanced, you get the following radio box:

* Highlight links as you press the Tab key
* Do not highlight links as you press the Tab key

if you choose not to, then you switch links by Option-Tab, if you choose to then its just Tab.

if apple is allowing it in their own browser, seems firebird should.
I keep hearing about this, there's no reason we shouldn't expose this.
Severity: major → normal
Flags: blocking1.0mac+
*** Bug 242831 has been marked as a duplicate of this bug. ***
*** Bug 250418 has been marked as a duplicate of this bug. ***
Blocks: 239175

Comment 12

13 years ago
Don't need to add a UI for it.

In "~/Library/Preferences/.GlobalPreferences.plist" look at "AppleKeyboardUIMode", bit 1 
toggles Full Keyboard Access. If the user's selected full keyboard access, then tab to all links, 
otherwise only tab to text fields.

Comment 13

13 years ago
(In reply to comment #12)
> Don't need to add a UI for it.
> In "~/Library/Preferences/.GlobalPreferences.plist" look at
"AppleKeyboardUIMode", bit 1 
> toggles Full Keyboard Access. If the user's selected full keyboard access,
then tab to all links, 
> otherwise only tab to text fields.

Agreed.


*** This bug has been marked as a duplicate of 187508 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
patch on bug 187508
Status: RESOLVED → VERIFIED
Flags: blocking-aviary1.0mac+
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.