After closing all windows, first new window is broken

VERIFIED FIXED in Firebird0.7.1

Status

()

defect
P1
normal
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: bugs, Assigned: bugs)

Tracking

unspecified
Firebird0.7.1
PowerPC
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

If you close all the firebird browser windows, the first new one you open has
some problems - e.g. bookmarks haven't loaded etc. This is because of an
incorrect assumption about the opener made in browser.js:Startup()
-> me, 0.7.1
Assignee: blake → bugs
Priority: -- → P1
Target Milestone: --- → Firebird0.7.1
Posted patch Patch to fixSplinter Review
On MacOS X, null check the sidebar box element, as it can be null if the opener
is the hidden window.

Comment 3

16 years ago
I assume this is technically a duplicate of bug 206752, although the fix is
here, so maybe that bug should now be duped against this one. Not that I'm
complaining, I'm just happy that you've found a fix :)

I also assume this will also fix bug 206456, bug 206933, bug 215176 and bug
220534, which probably should have been duped to the earlier bug anyway. I'm not
sure if the remaining issues in bug 204418 pertain to this or not.

Comment 4

16 years ago
WFM 20031024 Firebird/0.7+. Thanks Ben! I assume you checked in a patch.

All of the other bugs listed in my last comment seem to be fixed as well (except
for bug 204418, which I assume is a different issue altogether: a number of menu
things are still awry when NO windows are open at all). 
Fixed, 1.6a trunk and 1.5br

Wayne - yes, the menu problems with no windows open is different. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 206456 has been marked as a duplicate of this bug. ***
*** Bug 215176 has been marked as a duplicate of this bug. ***
*** Bug 206933 has been marked as a duplicate of this bug. ***
*** Bug 220534 has been marked as a duplicate of this bug. ***
verified fixed
Status: RESOLVED → VERIFIED
QA Contact: bugzilla

Comment 11

16 years ago
*** Bug 220454 has been marked as a duplicate of this bug. ***
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.