Closed Bug 223406 Opened 17 years ago Closed 17 years ago

Save page as (Web page, complete) does not save @imported style sheets

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 126309

People

(Reporter: rich, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

Style sheets associated with an HTML page using the LINK element work fine, but
style sheets that are imported through the STYLE element are not saved when they
should be.

e.g. the three style sheets in this code snippet should be saved with the HTML:

<style type="text/css">
@import "/css/present_global.css";
@import "/css/layout_global.css";
@import "/css/nav.css";
</style>

As an extension of this, external stylesheets can also link to other style
sheets in the same manner. These other stylesheets should be also be imported.

Reproducible: Always

Steps to Reproduce:
1. go to a site which @imports a style sheet, e.g. www.clagnut.com or
www.alistapart.com
2. File | Save Page As | Save as type:WebPage, complete 
3. Save

Actual Results:  
HTML is saved with a subdirectory containing media, script files, LINKed style
sheets but not @imported style sheets.

Expected Results:  
Style sheets specified through @import statements (whether in the HTML or an
external style sheet file) should also be saved and linked to appropriately.
Please look for duplicates before opening a bug.  This came right up with a
search for "save import".

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.