Last Comment Bug 223411 - implement Event "contentgenerated "
: implement Event "contentgenerated "
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: XBL (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
http://www.mozilla.org/projects/xbl/x...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 08:44 PDT by bugzilla.mozilla.org
Modified: 2016-06-01 07:03 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description bugzilla.mozilla.org 2003-10-23 08:44:39 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030924 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030924 Firebird/0.7+

the XBL Doku at
http://www.mozilla.org/projects/xbl/xbl.html#anonymous-generation describes an
even that probably would solve an Issue I'm currently facing:

I attack an XBL to an element and would like the XMB to reflect properties of
the surrounding document. I tried to do this in the constructor but this fails
because the surrounding elements seem to be not yet loaded. (another description
at
http://groups.google.com/groups?dq=&hl=en&lr=&ie=UTF-8&oe=utf-8&frame=right&th=56c79727bce6f37&seekm=bcsetk%24rfl3%40ripley.netscape.com#s)



Reproducible: Always

Steps to Reproduce:
Comment 1 Adam Becevello 2003-12-17 16:46:36 PST
setting severity -> enhancement
Comment 2 Anne (:annevk) 2005-03-30 02:14:33 PST
Hixie: will something similar to this still be in sXBL or XBL2?
Comment 3 Gervase Markham [:gerv] 2005-09-27 02:06:15 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Comment 4 bugzilla.mozilla.org 2005-09-28 12:42:09 PDT
seems still not implemented in gecko (though it's still documented on mozilla.org)
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2005-09-28 12:57:07 PDT
We should probably fix the docs instead; I'm not aware of plans to implement
this event.
Comment 6 Jonathan Kingston [:jkt] 2016-06-01 07:03:08 PDT
Closing this as I have removed the content on MDN as suggested by :bz as this won't be implemented.

Change here:
https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XBL/XBL_1.0_Reference/Anonymous_Content$compare?locale=en-US&to=1067062&from=1020392

Note You need to log in before you can comment on or make changes to this bug.