Unsetting review- flag sends incorrect email

RESOLVED FIXED in Bugzilla 2.20

Status

()

RESOLVED FIXED
15 years ago
6 years ago

People

(Reporter: bzbarsky, Assigned: LpSolit)

Tracking

2.20
Bugzilla 2.20

Details

(Whiteboard: [blocker will fix])

BUILD:  Whatever bugzilla.mozilla.org is using right not

STEPS TO REPRODUCE:

1)  xxx@yyy creates an attachment
2 [details] [diff] [review])  xxx@yyy sets a "review?" flag aimed at the email address foo@bar
3)  foo@bar sets the flag to "review-"
4)  xxx@yyy resets the flag back to "review?" aimed at foo@bar

EXPECTED RESULTS:

foo@bar gets an email saying that review is being requested

ACTUAL RESULTS:

foo@bar gets an email that says:

    Subject: review denied: [Bug XXXX] Summary [Attachment XXX] Attachment
             description

    <xxx@yyy> has denied <foo@bar>'s request for review:

Comment 1

14 years ago
I am having a similar (seemingly related) problem.  Consider a flag that goes 
from ? to +, then back to ?.  In that scenario, when the flag is changed from 
+ to ?, a "flag granted" email is sent to the person who originally set the 
flag to +.  This is consistently reproducible using bugzilla version 2.18.1.

 
(Assignee)

Updated

13 years ago
Assignee: myk → LpSolit
Depends on: 266147
OS: Linux → All
Hardware: PC → All
Whiteboard: [blocker will fix]
Target Milestone: --- → Bugzilla 2.20
Version: unspecified → 2.20
(Assignee)

Comment 2

13 years ago
fixed!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.