If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

asking for incorrect user to log into smtp server

RESOLVED DUPLICATE of bug 90507

Status

Thunderbird
Preferences
--
major
RESOLVED DUPLICATE of bug 90507
14 years ago
13 years ago

People

(Reporter: Don Sachnoff, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla Thunderbird 0.3 (20031013)

I created an account called "Regular".  The pop3 id is pop3.covad.net abd the
smtp server is smtp.covad.net.  When I create a new email and send it,
thunderbird is trying to authenticate me using the email I address
(kx9q@smtp.covad.net) rather than the user name given under server settings. 
kx9q@arrl.net is a forwarding service hence covad will know nothing about it. 
Mozilla v1.5 email works fine without issue and Mozilla's email is setup the
same way as Thunderbird's email.

Reproducible: Always

Steps to Reproduce:
1.create an email
2.attempt to send email
3.

Actual Results:  
enter password for kx9q@smtp.covad.net pop up appears

Expected Results:  
it should have shown my real userid@smtp.covad.net

Comment 1

14 years ago
see bug 90507

Have you ever tried to enter your password and see if it works?
The string username@smtpserver.com shown in the password dialog is not used for
login, just the username part is relevant.
Set the correct username in "Account settings > Outgoing Server". This one is
used when Thunderbird tries to login on the SMTP server.

*** This bug has been marked as a duplicate of 90507 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.