Proposed new "Mozilla Browser" Icon

RESOLVED WONTFIX

Status

()

Firefox
General
--
enhancement
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: Brian, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: 

This icon is intended to solve a number of issues:

- Currently, Mozilla Firebird has a nondescript icon.
- The current proposed icon (see 
http://www.actsofvolition.com/steven/mozillabranding/) , while attractive and 
professional, brands the product as "firebird" (note the "F"). Going forward, 
Mozilla Browser, the new name for Mozilla Firebird, will need an icon that 
both describes what it does and brands it as a Mozilla.org application.
- Windows XP uses true color icons, up to 48x48 pixels in size. It also uses 
32x32 pixel icons, 24x24 pixel icons(Start Menu), and 16x16 pixel icons. 
Simply resizing the image results in an unreadable blur. The icons *must* be 
hand-hinted so that they are clear at small sizes.
- Mac OS X uses 128x128 pixel icons. They are resized in real time. Any icon 
*must* fit the Mac OS X visual style. The icon must also be similar enough (or 
the same as) the Windows icon to signify that the program is indeed the same 
as the Windows version.
- GNOME and KDE accept either scaled PNG images or SVG. SVG icons are ideal as 
they are clearer at larger sizes. Any icon developed must be vectorized to 
facilitate the transition to SVG.

I have created an icon that I believe fits all of this criteria. It is simple 
yet universially recognizable. The user immediately knows that the product is 
in fact a web browser, and the "M" logo is included to signify that it is a 
Mozilla.org product. The icon is vectorized (EPS and Macromedia Flash) and is 
rendered in six sizes, from 16x16 to 128x128. Below 64x64, the icon is hand-
hinted to add more clarity and detail. Even at 16x16 pixels it is clear that 
the application is both a web browser and a Mozilla.org application.

You can view a preview at of the different sizes:
http://cwcairns.home.comcast.net/preview.png

Or, download the RGBA PNG images and vector source at:
http://cwcairns.home.comcast.net/globe.zip



Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 134008 [details]
Preview of the icons

Comment 2

14 years ago
*** Bug 223504 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
->General, not History
Component: History → General
(Reporter)

Comment 4

14 years ago
Created attachment 134094 [details]
Preview of the proposed Mozilla Browser (currently Mozilla Firebird) and Mozilla Mail (currently Mozilla Thunderbird) icons.
(Reporter)

Comment 5

14 years ago
Created attachment 134095 [details]
Proposed Mozilla Browser (currently Mozilla Firebird) and Mozilla Mail (currently Mozilla Thunderbird) icons in RGBA PNG and EPS formats.
(Reporter)

Updated

14 years ago
Attachment #134008 - Attachment is obsolete: true
(Reporter)

Updated

14 years ago
Attachment #134094 - Attachment description: Preview of the proprosed Mozilla Browser (currently Mozilla Firebird) and Mozilla Mail (currently Mozilla Thunderbird) icons. → Preview of the proposed Mozilla Browser (currently Mozilla Firebird) and Mozilla Mail (currently Mozilla Thunderbird) icons.

Comment 6

14 years ago
These new icons are very slick. :0) I particularly like the mail one. However, I
thought I would point out that the currently proposed new thunderbird icon
matches the toolabar icons (for get mail, reply, forward etc.) which is a good
thing.

I think your incorporation of the mozilla M is a good idea, (though I like the
flames too...) :0)

I'm confirming, though I'm not sure where this belongs... maybe browser general?
I'll leave it in firebird for now.

Adding new to summary to help searches.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Proposed "Mozilla Browser" Icon → Proposed new "Mozilla Browser" Icon
just going to WONTFIX this, the icon will be changed, but the branding is
already shifting slightly
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.