Incorrect Count in Status Line on Get Mail

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: rich cowan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla Thunderbird 0.3

If you download messages, and some messages do not
come down because they are larger than the "maximum"
size you have set under the "disk space" option
in preferences, and then you change the option to
allow downloading the message, an incorrect message
could will appear in the status line when you get mail.

Reproducible: Always

Steps to Reproduce:
1. Set the option Tools->Account Settings->Disk Space to a low number
2. Check your mail
3. Change the setting in 1. to a higher number
4. Check mail again

Actual Results:  
The status line, if 1 message is to be downloaded, will
say "Downloading message 1 of 0".  I assume if there
are 3 messages it would say "downloading message 3 of 0"
and that it could even read "downloading message 5 of 3" in
certain situations...  if there are new messages too.

Expected Results:  
It should say "Downloading message 1 of 1": the # of messages
to be downloaded is the number of new messages PLUS the number
of incomplete messages that are to be completed due to the
change in the "Disk Space" setting.

Comment 1

13 years ago
I have been getting a similar error. No message is downloaded, because one of
the mail servers I usually connect to is unavailable and there is no messages on
the other. The message count is set to "1 message received" in the icon
notification area and the income message sound is played.
QA Contact: front-end

Updated

10 years ago
Assignee: mscott → nobody

Comment 2

5 years ago
I cannot reproduce. And both users involved in this bug kindly indicated they no longer user thunderbird.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.