Sent Folder Loses Track of Which Messages Have Attachments

RESOLVED DUPLICATE of bug 199979

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 199979
14 years ago
14 years ago

People

(Reporter: rich cowan, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla Thunderbird 0.3

I wanted to clean up my disk space so I painstakingly
deleted emails from my sent folder that had attachments.
FYI I have been using 0.1, 0.2, 0.3.

After doing this, my sent folder was still 22Mb so I
opened up the sent folder in WordPad and noticed that
many attachments remained.  When I move the cursor to
the messages that should have been marked as having
attachments the icon changed to indicate that in fact
the attachment existed.  

Note that when I compacted the folder, messages marked
as having attachments seemed to remain marked as such,
even after closing and reopening Thunderbird.

This is reproducible only if someone has had the same
experience with an 0.3 only install.  My test is a bit
suspect because I have used 3 different builds.

Reproducible: Didn't try

Steps to Reproduce:
1. Use Thunderbird for a while and send a number of files with attachments.
2. Remove all of the files from "sent" folder with attachments.
3. Go to C:\Documents and Settings\default\Application Data\Thunderbird\Profiles
   and look for your mail folder for your active account and open the "sent"
   file in Wordpad, see if there are remaining attachments.

Actual Results:  
I saw attachments in the file, noted the date on them, and
then went back into my sent folder in Thunderbird to call up
the offending messages.

Expected Results:  
1.  Thunderbird should not lose track of what has attachments.
2.  There should be a right-click option on any folder to either:
    a) remove all attachments from messages to save space, or
    b) delete all messages with attachments, to save space.
3.  When you right-click on a folder and choose properties, the
    info displayed should include the number of messages in the
    folder as well as the total size of the mailbox.  The number
    of messages with attachments would be a useful piece of data.

Comment 1

14 years ago
This is a duplicate.
Displaying/deleting messages that contain attachments can be done by using
message views.

*** This bug has been marked as a duplicate of 199979 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.