bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

events sent to wrong tab when running embedded Acrobat Reader

RESOLVED WORKSFORME

Status

Plugins Graveyard
PDF (Adobe)
--
major
RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: Bryan Mills, Unassigned)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When multiple tabs are open and one or more of them is Acrobat Reader 6.0 (this
is probably an issue with other full-window plugins, but this is the one I'm
using), if Mozilla loses window focus and then regains it, subsequent keyboard
and mouse events are dispatched to the embedded Acrobat Reader instead of the
active tab.  This continues until a mouse click occurs within the document body
(effectively disabling keyboard shortcuts and menus until this occurs).

Reproducible: Always

Steps to Reproduce:
1. Open a PDF with Acrobat Reader in a separate tab from a normal HTML document
2. Select the tab for the normal HTML document
3. Select the window of another application
4. Select Mozilla by clicking on the Windows taskbar, alt-tab, or clicking on a
non-document portion of the Mozilla window
5. Perform an action, such as mouse-wheel scrolling, clicking on menus, and ctrl-W

Actual Results:  
Acrobat Reader recieves scrolling information and ctrl-W, and menus do not open.

Expected Results:  
The document associated with the active tab should have scrolled and closed, and
menus should have opened when clicked.

May be Firebird-only bug -- has not been tested with Seamonkey.
.
Assignee: events → peterlubczynski-bugs
Component: Event Handling → Plug-ins

Comment 2

14 years ago
I can confirm this behavior, but it might be a dupe. All these plugin window /
tab event bugs look like a common thread.

possible dupes
Bug 223575 - events sent to wrong tab when running embedded Acrobat Reader

Bug 231891 - controls in background tab of a quicktime plugin are active in
foreground tab or second mozilla window

Bug 233780 - Flash continues to respond to events (like mouseover) even on
another tab not in the foreground.
	 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME

Comment 3

14 years ago
I can confirm this bug in FireFox .8 also. I've beek killing my acroread and
have noticed that it was related to embeded instances and how they interact with
other instances launched direclty from pdf files outside of the mozilla
interface. Sometimes it seems as though the reader actually hangs due to this
and causes FireFox to freeze up, but that may not be directly related.

Comment 4

13 years ago
I havent't been able to find a dupe for this. Also, this issue is not acrobat
reader only issue, also happens with other plugins.

See the following bugs that seem to be the same issue:
Bug 272849
Bug 273456

Comment 5

12 years ago
I find this behaviour also without active plugings. For example, right-click->"select all" sometimes selects the text in another tab.
QA Contact: ian → plugins

Comment 6

9 years ago
is this problem gone for everyone?  
I don't recall ever seeing this with v2 or v3 on windows
Assignee: peterlubczynski-bugs → nobody

Updated

8 years ago
Component: Plug-ins → PDF (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-reader
Version: Trunk → unspecified

Comment 7

7 years ago
WFM, current trunk and PDF
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 8

7 years ago
but if you still see this it should dup to bug 273456

Comment 9

7 years ago
Bug 273456 is still valid, but is not an exact duplicate of this. The current bug uses switching to other application, after which the focus is still bad (or actually gets broken by this action). In my tests, switching to other app fixes the focus (that was broken in the way described in bug 273456).

Updated

5 years ago
Whiteboard: DUPEME
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.