undefined entity error in navigator.xul when firebird is the default browser and a url is launched

RESOLVED DUPLICATE of bug 210553

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 210553
14 years ago
13 years ago

People

(Reporter: Patrick Walsh, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When a program tries to open a URL in the default browser, such as when .webloc
files are opened, and that default browser is Firebird under OSX 10.2.8, the
following error pops up:

XML Parsing Error: undefined entity
Location: chrome://navigator/content/navigator.xul
Line Number 46, Column 1:
<window id="main-window"
^

To try to reduce the possibility that I'm the only one experiencing this, I
installed a fresh Firebird (version 0.7) after deleting my ~/Library/Pheonix
directory.  Didn't solve the problem.  I can't think of anything special on my
Powerbook G4 that could influence this error.

Reproducible: Always

Steps to Reproduce:
There are many ways to reproduce this.  Here's one of the easiest: drag a URL
from the location bar to your desktop and a .webloc file will be created.  Make
sure Firebird is your default browser, and double-click the .webloc file you
created.  You should get the above error.

Actual Results:  
A small window opens up and displays this error:

XML Parsing Error: undefined entity
Location: chrome://navigator/content/navigator.xul
Line Number 46, Column 1:
<window id="main-window"
^


Expected Results:  
Opened the URL.  Note that in the case with the .webloc file, dragging it onto
the window works.  But there is no workaround when, for example, I try to open a
URL from NetNewsWire.

I'm using the Mozilla Firebird theme.  I haven't tried an alternate, but I'll do
that after posting this.  

This is the only thing preventing me from making Firebird my default browser. 
To me, that makes it a major bug, but feel free to reclassify it...

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 210553 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.