Opening or closing sidebar after canceling out of Search dilog ledas to a crash

VERIFIED DUPLICATE of bug 22360

Status

SeaMonkey
Sidebar
P3
critical
VERIFIED DUPLICATE of bug 22360
19 years ago
14 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Steve Lamm)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
** Observed with 12/21/99 Win32 M12 final candidate build **

This is a very annoying bug.
Here's stpes to reproduce this bug.

1. Start up Mozilla Browser.
2. Engage "Search | Find on this page" dialog.
3. (You can do real search but this is not necessary). Just cancel
   thi serach by clicking on the Cancel button.
4. Once the search dialog is closed. Try to close or open
   the sidebar by clicking on the side bar's "vertical bar
5. This leads to a crash without a fail.
(Reporter)

Comment 1

19 years ago
I filed several crash reports to Talkback but so far the following
is the only one I can retrieve at this point. If the subsequent ones
are different from this, I'll amend it later.
Here's the first such report I could retrieve:

--------------------------------------------------
Trigger Type:  Program Crash

Trigger Reason:  Access violation
Call Stack:    (Signature = nsEventStateManager::SendFocusBlur 371fee3a)
nsEventStateManager::SendFocusBlur
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
1930]
nsEventStateManager::ChangeFocus
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
1428]
nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line
542]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2658]
nsView::HandleEvent  [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 841]
nsView::HandleEvent  [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 826]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1678]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 425]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 442]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3334]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3550]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2646]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 609]
USER32.dll + 0x1186 (0x77e41186)
0x015800a8
--------------------------------------------------

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
From the stack crawl, this looks like a dupe of bug #22360.


*** This bug has been marked as a duplicate of 22360 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
yep
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.