mozilla-1.6a/plugins/libnullplugin.so returned 1402ea490

VERIFIED INVALID

Status

()

Core
Plug-ins
VERIFIED INVALID
15 years ago
8 years ago

People

(Reporter: Martin Mokrejs, Assigned: Peter Lubczynski)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030826
Build Identifier: nightly snapshot from yeaterday

Hi,
  I'm getting on startup on Tru64Unix the following message:

WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsChromeRegistry.cpp,
line 3188
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsChromeRegistry.cpp,
line 3188
GFX: dpi=75 t2p=0.0526316 p2t=19 depth=24
WEBSHELL+ = 1
LoadPlugin() /afs/.gsf.de/@sys/usr/lib/mozilla-1.6a/plugins/libnullplugin.so
returned 1402ea490
GetMIMEDescription() returned "*:.*:All types"


What does that mean?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
That's just the return code from the function.  You're running a debug build, so
you're getting all sorts of debugging output... To someone trying to debug a
plugin problem, that return code could be useful.

Marking invalid, since there's no bug here.
.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

15 years ago
But the output be labeled with "Debug: " in front of the line?
No.  All the output you see there is debug output.   In non-debug builds,
Mozilla itself should not print anything to stdout.  If it does, _that_'s a bug.
(Reporter)

Comment 5

15 years ago
Yes, you might be right, but in this "debug" output there's somewhere an error,
and it terribly difficult to find that. Look for Tru64Unix bugs and you will see
what I mean. Labelling debug lines with "Debug:" does not hurt, right? :)

Comment 6

8 years ago
since *all* lines are debug output, labeling *all* lines with Debug: would not help, and having to do it would hurt (plus it'd break our tests).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.