Firebird crashes when starting up

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Doeke Zanstra, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85.7 (KHTML, like Gecko) Safari/85.5
Build Identifier: n.a. (Finder reports version 1.4a)

Details from console:
/Applications/Browsers/Mozilla Firebird.app/Contents/MacOS/MozillaFirebird-bin: can't map file: 
/Applications/Browsers/Mozilla Firebird.app/Contents/MacOS/plugins/Default Plugin.plugin ((os/
kern) invalid argument)
/Applications/Browsers/Mozilla Firebird.app/Contents/MacOS/MozillaFirebird-bin: can't map file: 
/Library/Internet Plug-Ins/QuickTime Plugin.plugin ((os/kern) invalid argument)

Reproducible: Always

Steps to Reproduce:
1.Double click the Firebird icon
Actual Results:  
1.Firebird icon in the dock "jumps" (indicating it's loading)
2.Firebird icon in the dock disappears

Expected Results:  
1.Firebird icon in the dock "jumps" (indicating it's loading)
2.Firebird is loaded

I have the latest updates from Apple (Mac OS X 10.2.8)

Comment 1

15 years ago
wfm, 20031022 0.7.1 test.  where did you get this version?

Comment 2

15 years ago
Forgive me if this is a stupid question, but when you downloaded Firebird, did
you copy the bundle icon from the disk image folder to your application folder,
and then drag the copied version to the dock? You didn't copy the icon to the
dock directly from the disk image, did you? :)
(Reporter)

Comment 3

15 years ago
Doesn't mather, but forgive me my stupid answer ;-) 

A bit more detailed "steps to reproduce" then:
1) I copied the (bundle) icon to my browsers folder (/Applications/Browsers). 
2) Then I started Firebird from the finder at /Applications/Browsers
3) The Firebird icons appears bouncing in the dock (indicating it's loading)
4) Then the bouncing stops and an triangle appears below the icon (indicating 
it's loaded and active)
5) 1 or 2 seconds later the icon disappears from the dock
6) Now I only get the first message in my console, mentioned above.

I tried moving the the bundle to the /Applications folder and start it from 
there. Same result.

I did not move the bundle to the dock.

I got this version from the www.mozilla.org frontpage, say, a week ago. So I 
didn't trust it, and just now I downloaded an other copy. On the frontpage, 
it's identified as Mozilla Firebird 0.7 and the URL suggests version 0.7.1). 
Same behaviour, but the first bundle is 31.8 MB and this bundle is 27 MB. The 
finder reports for both bundles Version 1.4a.

Comment 4

15 years ago
Weird. Sounds like something's causing it to crash during loading.
Ok, couple more questions:
1. If you click and hold on the icon in the dock, then select "Show In Finder",
does it bring up the correct copy of Firebird in your Applications folder?
2. In the Library folder in your Home directory, drag the folder "Phoenix" to
the trash. Will Firebird start then? Your current profile may be corrupted.
(Reporter)

Comment 5

15 years ago
Deleting the ~/Library/Phoenix does the trick. It's running now: my problem is 
solved.

Comment 6

15 years ago
Great to hear! Your old profile must have been corrupted or just incompatible.
It's usually recommended to remove your old profile when installing a new
version of Firebird, because it's a new and rapidly evolving piece of software.
I just rescue my bookmarks and that's about it.

Comment 7

15 years ago
Looks like a dupe of Bug 205769

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.