If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No LF + CR in mailto href

RESOLVED DUPLICATE of bug 220099

Status

MailNews Core
Networking
RESOLVED DUPLICATE of bug 220099
14 years ago
9 years ago

People

(Reporter: Davide Melan, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.5) Gecko/20031007

escape chars %0d%0a works fine with Mozilla <= 1.4 (and IE)
but fails with Mozilla 1.5

Reproducible: Always

Steps to Reproduce:
put the code
<a href="mailto:duffy@duck.com?subject=test mail&body=mail body%0d%0abye">mail
the message</a>
in a html source and follow the link

Actual Results:  
the body of the mail is

mail bodybye

Expected Results:  
instead of 

mail body

bye
-> mailnews, I suppose
Assignee: general → sspitzer
Component: Browser-General → Networking: MailNews General
Product: Browser → MailNews
QA Contact: general → gchan

Comment 2

14 years ago
Doesn't the html spec say something about ignoring line feed escapes? Just a
vauge memory, might be completely wrong...

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 220099 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.