Empty new tab cannot be closed with Ctrl+W

RESOLVED DUPLICATE of bug 189615

Status

()

RESOLVED DUPLICATE of bug 189615
15 years ago
13 years ago

People

(Reporter: jquelin, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Under Linux (not windows), if you create a new tab, either with Ctrl+T or with
File / New Tab, you cannot close it with Ctrl+T.
To close it, you must:
 - either File / Close Tab
 - or right click on the tab + Close Tab
 - or (start to) load something and then Ctrl+T will work

Reproducible: Always

Steps to Reproduce:
1. Ctrl+T to create a new tab
2. Ctrl+W to close it
3. watch the empty tab still in the windows

Actual Results:  
The empty tab is still present.

Expected Results:  
The empty tab shouldhave been closed.

Comment 1

15 years ago
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: empty new tab cannot be closed with Wtrl+W → Empty new tab cannot be closed with Ctrl+W

Comment 2

15 years ago
Is it failing to close because it's empty or because the address bar has focus?
(Reporter)

Comment 3

15 years ago
with an empty new tab:
 - location field has focus => cannot close tab with ctrl+w
 - search field has focus => cannot close tab with ctrl+w
 - empty tab has focus => can close tab with ctrl+w

Comment 4

15 years ago
Still broken?  
(Reporter)

Comment 5

15 years ago
Sorry for the delay, I took some time to realize that some nightlies do not
require Xft (which I don't have - and can't install without upgrade of XFree86).

Anyway, with:
 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
 Gecko/20040104 Firebird/0.7+

the problem is still there.

In fact, I also found that the following ctl+key do not work when the address
bar has the focus:
 - ctrl+B (bookmarks)
 - ctrl+D (bookmark this page)
 - ctrl+E (downloads)
 - ctrl+F (find)
 - ctrl+H (history)
 - ctrl+K (search field)
 - ctrl+U (page source)

However, the following ctrl+key work:
 - ctrl+G (find again)
 - ctrl+I (page info)
 - ctrl+N (new window)
 - ctrl+O (open file)
 - ctrl+P (print)
 - ctrl+S (save)
 - ctrl+T (new tab)

I agree that most of those shortcuts are useless with an empty page, but if some
of these useless shortcuts work (ctrl+I), then they should all work. Plus, some
of them are really interesting even on a blank page (ctrl+B, ctrl+H, ctrl+K)


Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040110 Firebird/0.8.0+
(daihard: XFT+GTK2; optimized for P4/SSE-2)

The bug is still present. After using Ctrl-T to open a new tab, Ctrl-W will not
close it.
Sorry for the bugspam, but after checking, it appears to be a focus problem -
clicking once in the tab render space after bringing it up focuses on the tab.
After that, Ctrl-W works.

Comment 8

15 years ago
WFM on Windows XP, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040128 Firebird/0.8.0+.  The only shortcut that doesn't work for me in
blank tabs is Ctrl+Tab (bug 227887).

Maybe the shortcuts Jerome listed in comment 5 don't work on Linux because
they're interpreted as Emacs text-editing commands when the address bar has focus.

Comment 9

15 years ago
Should the summary be changed from "Empty new tab cannot be closed with Ctrl+W"
to "Ctrl+W doesn't close tab when address bar has focus"?
Now about "Newly spawned tab cannot be immediately closed with Ctrl-W" to show
that it's a focus problem?

Comment 11

15 years ago
A tab also cannot be closed with Ctrl+W if an <input> or a <textarea> element in
a webpage has the focus.
(Reporter)

Comment 12

15 years ago
Firefox on Solaris has the same problem (can we extend it to all non-windows
platforms?)

Comment 13

15 years ago
Same problem here on FreeBSD:
Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.6) Gecko/20040227 Firefox/0.8

Comment 14

15 years ago
*** Bug 238967 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago

*** This bug has been marked as a duplicate of 189615 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.