Even with "enable all cookies", *some* sites fail to see that they are enabled.

RESOLVED INVALID

Status

()

Core
Networking: Cookies
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Richard Neill, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Some websites (but not others) complain that cookies are disabled, even when
"enable all cookies" is selected. This happens on both Moz 1.4/WinXP and Moz
1.5/Linux. (I've tried restarting Moz. to no avail.)

Some sites that don't work:
http://www.just-the-name.co.uk
http://www.hertz.co.uk

Some sites that do work:
www.slashdot.org
www.mandrakeclub.com

Some other bugs which may have the same root cause:
179405
176837
179405
186015
192035
198455
200940
202891
204355
210726
215002
218811
220208
180831


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Do you allow JS to set and read cookies?

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6a) Gecko/20031024

Javascript disabled, I get a page telling me to enable Javascript.
If I enable all of it, I get to the normal page to select my country.
Disabling read/write cookies via javascript, I´m getting another page telling me
to enable cookies. Cookies were enabled, but not the cookies via javascript.

My settings:
Privacy&Security->Cookies:
- Enable cookies for the originating website only
- limit lifetime of cookies to: current session

Privacy&Security->Images: Accept All ... / As many times ...
Privacy&Security->PopUps: blocked

Advanced->Scripts&Plug-Ins: 
Enable Script for: Navigator
Allow scripts to: All checkboxes checked 

If I uncheck one or both of the last two checkboxes (create/change/read cookies)
the cookie error webpage is loaded instead of the target webpage.

Does this work for you?

(Reporter)

Comment 3

14 years ago
Thanks for that. I had JS allowed to "Read cookies" but not to "Create or change
cookies".

Can I suggest that this should be mentioned on the
Edit->Prefs->privacy and security->Cookies   page.
It's very very easy to make that mistake otherwise. 

Perhaps a warning 
if ((cookes are allowed) AND (JS cannot create/change cookies)){
    print in red: "You have enabled all cookies here, yet some sites may 
   still not  be able to use them because you have turned them off in JS.
   This is inconsistent - please change it in Advanced->Scripts & plugins"
}


(Of course, any site that uses JS in this way is badly designed!)

Comment 4

14 years ago
Thanks for the huge list of open bugs you have searched, and a very good bug
description, but it would be more comfortable, when you are writing bugnumbers,
to precede them with the word bug, so they get linkified, like this: bug 106490,
 seems also to be an interesting bug. 

Cookies via JS:
Many websites use JS in this way, as this was the way cookies were working in
NS4.7 even if blocked. 
Marking bug as WORKSFORME according to last comment of reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

14 years ago
I am not sure "Worksforme" is quite sufficient - in that it's an easy mistake to
make, and a very obscure one. Other people will make the same error, and will
not understand why! They won't be able to fix it either (most sites simply tell
you to enable cookies - and that's not sufficient.)

I think it's important to change the explanation on this page:
Edit->Prefs->privacy and security->Cookies
perhaps using the text I suggested in #3. 

Also, if cookies are NOT blocked, but JS blocking DOES effectively block
cookies, then the cookie notification icon should be triggered to say:
"You have blocked Javascript from reading/writing a cookie. Although you have
allowed all normal cookies, this site will *still* be unable to use them because
it accesses them via Javascript. (You can change this in Advanced->Scripts &
plugins.)

Similarly, if I have disabled cookies, I don't want them to be able to be read
by Javascript. 

The root cause is this:
****
There are 2 different ways to permit/block cookies depending on whether the
access mechanism uses Javascript or not. These options have controls in
different places, and can be set inconsistently with each other! Ideally, both
methods should be switched on/off at the same time, using just one cookie
control. Alternatively, there should be a clear explanation on each of them to
warn of this inconsistency.
*****

P.S. Thanks for pointing out the bug linkification to me. For ease of future
use, here's the list again:

bug 179405
bug 176837
bug 179405
bug 186015
bug 192035
bug 198455
bug 200940
bug 202891
bug 204355
bug 210726
bug 215002
bug 218811
bug 220208
bug 180831
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

14 years ago
the solution is to remove the JS cookie prefs. it's nonsensical to have a pref
for one specific mode of setting a cookie, and not for the others.

i've filed a separate bug about that, bug 223782. this bug is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.