Open Bug 223766 Opened 16 years ago Updated 7 years ago

Allow brackets around nickname to be copied

Categories

(Other Applications :: ChatZilla, enhancement)

enhancement
Not set

Tracking

(Not tracked)

People

(Reporter: mozilla-bugzilla, Assigned: rginda)

References

(Depends on 1 open bug, )

Details

(Whiteboard: [cz-0.9.71])

Attachments

(1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.5) Gecko/20031007

The brackets around the nicknames in ChatZilla are not copied along with the
rest of text.

Reproducible: Always

Steps to Reproduce:
1. Log onto irc
2. Copy a line of text

Actual Results:  
Pasting the text does not include the brackets surrounding the nickname.

Expected Results:  
Mozilla should have included the brackets around the nickname for clarity.
This should probably be a dup, but I'll make a dependency instead to avoid
duplicates and make it easier to track.

It's a mozilla bug, not something that chatzilla can fix.
Status: UNCONFIRMED → NEW
Depends on: 12460
Ever confirmed: true
Product: Core → Other Applications
Attached patch Patch (obsolete) — Splinter Review
Patch/Hack to make the brackets that go into logfiles hide inside the output document as well, allowing copying. Thanks to Silver for just about everything in the patch (I only fussed about a few optimizations).
Attachment #210161 - Flags: review?(samuel)
>                 // From us to a user.

Is probably better off as:

>                 // From us, on a channel or network view, to a user.

to maintain code clarity.
Attachment #210161 - Flags: review?(samuel) → review+
Checked in.

I suppose we should really be marking this 'HACKEDAROUND', but for lack of a better resolution --> FIXED.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: rginda → gijskruitbosch+bugs
Status: REOPENED → NEW
Status: NEW → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.71]
This started happening again on my machine after upgrading to Firefox 4. I'm using ChatZilla 0.9.86.1 on Linux (KUbuntu).

(This bug should be REOPENed, but I don't seem to have the required permissions to do that.)
Comment #5 is right, it seems by now display: none; content is no longer being copied. We could probably hide it some other way... maybe width: 0; ?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Bug 39098 is the top suspect for causing this; it looks like they're disregarding anything that doesn't have a Gecko display frame.

I got some success with "width: 0; height: 0; overflow: hidden; display: inline-block;" but inline-block is relatively new in Gecko...
QA Contact: samuel → chatzilla
Assignee: gijskruitbosch+bugs → rginda
Status: REOPENED → NEW
Attachment #210161 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.