hidden window shows up during exposé feature

VERIFIED DUPLICATE of bug 223545

Status

()

VERIFIED DUPLICATE of bug 223545
15 years ago
11 years ago

People

(Reporter: zanneth, Assigned: bugzilla)

Tracking

({fixed-aviary1.0, polish})

unspecified
PowerPC
Mac OS X
fixed-aviary1.0, polish
Points:
---
Bug Flags:
blocking-aviary1.0mac +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

When I press F9/F10 for the new feature in Panther called "Exposé", there is a
small window that shows up and I cannot get rid of it. Its a small thing, but
its quite annoying...

Reproducible: Always

Steps to Reproduce:
1. Closed all windows in program.
2. Restarted
3. Checked preferences menus etc.

Actual Results:  
Nothing was fixed.

Expected Results:  
Mozilla Firebird should have shown only the windows that I actually had open
when using the Exposé feature.

Comment 1

15 years ago
I have noticed for some time that when I alt-~ through the open windows in
Firebird there is a hidden window of some kind: the other windows title bars
will dim, but there is no apparent window. It seems that this is the same
problem, now revealed more easily using Expose.

Comment 2

15 years ago
Confirming. See also Bug 223545, this bug's twin in Mozilla Proper, and Bug
150028, the original Hidden Window on Mac bug (featuring the option-minimize and
command-~ appearances of the elusive window)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
*** Bug 225613 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
*** Bug 242373 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
the hidden window gets the menubar functional again incomplete workaround of Bug 21296 and keeps 
the firefox open if no window is visibly open.

Comment 6

15 years ago
fixing this would make firefox on mac look much cleaner.
Flags: blocking1.0?
Keywords: polish
Flags: blocking1.0? → blocking1.0+
Flags: blocking1.0+ → blocking1.0mac+

Comment 7

15 years ago
*** Bug 249860 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
Can confirm this behavior using Mac OS X 10.3 and Firefox 0.9.1

Its probably the most annoying cosmetic bug I've noticed, and definetly needs
fixing before 1.0

Interesting, it doesn't occur when I am running in dual screen mode with my CRT,
only when I am running using my Powerbook's LCD screen by itself.

Comment 9

15 years ago
To stop a window from being affected by Exposé, you should be able to adapt this code: http://
www.cocoabuilder.com/archive/message/2004/2/12/96974

However, the hidden window will still be noticeable when using command-tilde to cycle windows.
The CGSTagSticky hack doesn't block the movement of the window during Exposé's
"Show Windows", only during "Show Desktop".

Comment 11

15 years ago
I do *not* witness this behavior using Firefox 0.9.1 under OS X 10.3.4.

Comment 12

15 years ago
(In reply to comment #11)
> I do *not* witness this behavior using Firefox 0.9.1 under OS X 10.3.4.

I have the same setup and witness this behavior when pressing both F9 and F10.
So I don't think this has been fixed.
(In reply to comment #11)
> I do *not* witness this behavior using Firefox 0.9.1 under OS X 10.3.4.

Sometimes, you'll see this as a minimized winodw in the dock.

*** This bug has been marked as a duplicate of 223545 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
It is fixed now (see bug 223545).
Status: RESOLVED → VERIFIED
Keywords: fixed-aviary1.0
You need to log in before you can comment on or make changes to this bug.