Composition inop replying - strange caret locations, etc

VERIFIED FIXED in M15

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Michael Collette, Assigned: Joe Francis)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using build 1999122108 on NT 4.0 trying to reply to a message on Mozilla's
wishlist group.  To reproduce...

1. Log into newsgroup or mail and get messages.
2. Select a message to read.
3. Reply to that message.
4. Type in a word, then press Enter.

At this point the cursor changes size and the action of the cursor is very
nearly random.  Backspacing and hitting Enter act differently depending on the
cursor size at the time, but never quite as expected.  Double-clicking into the
message can have similar results.

In an attempt to better document this I re-ran this a number of times.  During
this testing I had Mozilla completely crash on me at various points.  Once while
mucking around with the cursor in the message, once just trying to launch
mail/news, and yet again by just hitting reply.  Apparently the reply button
crash can be simulated by hitting reply, close the window, repeat process a
couple of times until dead.

The weird text effects are not happening when composing a new message.  You can
cause a Mozilla crash by opening a new mail, closing it, repeat a couple of
times rapidly.

Was not able to reproduce this problem on Linux using build 19999122023, though
performance really, really stinks for mail on that side.  It's working, just
really slowly.  Running that on a 233MMX with plenty of memory.
(Reporter)

Updated

19 years ago
Severity: critical → normal
(Reporter)

Comment 1

19 years ago
Moved severity down from Critical to Normal.  Ran this on the M12 release which
is sporting a higher build number and ran into some buggy behaviour, but not
dumping Mozilla.  At least it's a repeatable buggy this time.

For this build, when replying to a message enter a word and press Enter.  All
the lines below move down one, but the cursor stays put.  Hit Enter again and
the cursor moves down a line, but nothing else moves.

This bug still effects replying to either mail or news.  New mail composition
works just peachy, no problems of this sort.

Updated

19 years ago
Summary: Composition inop replying → Composition inop replying - strange cursor locations, etc

Comment 2

19 years ago
Are you in HTML or plain text mail compose?
Does this occur if you go into Tasks | Composer?  The composer window appears.
Then, choose Debug | Compose with test page.  See if the same problem with the
cursor positioning occurs.

On a different subject, the problem with closing the compose window several
times and crashing may be overed under
http://bugzilla.mozilla.org/show_bug.cgi?id=22329
(Reporter)

Comment 3

19 years ago
First off, I concur that Bug #22329 looks to be a dupe of the open composition
that I reported.  Looking forward to see if the posted fix helps out.

Composer looks good for cursor positioning so far as I can tell.  Double click
at the end of a line of text causes the cursor size to change.  Looks to be
about 1/3 smaller than normal, but returns to normal once you resume typing.  It
looks a little funny, but has no adverse impact on positioning.  Within the mail
composition seeing that cursor size change is an indicator that it's about to
act funny on ya.

The mail client composition seems to be the primary location for this bug.
Using HTML editing here, but not adding any HTML formatting during my testing.
Both Mail and Composer have horrid memory leaks though, as reported in Bug
#22395.  There may be some relationship to that.

Updated

19 years ago
Assignee: ducarroz → beppe
reassign to editor team for investigation

Updated

19 years ago
Assignee: beppe → jfrancis
Target Milestone: M15

Comment 5

19 years ago
assigning this to jfrancis
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
accepting bugs

Updated

19 years ago
Summary: Composition inop replying - strange cursor locations, etc → Composition inop replying - strange caret locations, etc

Comment 7

19 years ago
Changing summary from "cursor" to "caret"
(Assignee)

Comment 8

19 years ago
i need some more info on this:
Is it plaintext or html reply?
Do you have the prefs set so that your text goes above the quoted text, or below 
it?

thanks.
(Assignee)

Comment 9

19 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 10

19 years ago
metrol@metrol.net - is this better/fixed for you now?

Comment 11

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.