If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Latin and Cyrillic parts seem to use different fonts

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
14 years ago
2 years ago

People

(Reporter: Vladimir NOVIKOV, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7

This bug is found in Mozilla, Firebird and Thunderbird while browsing or reading
and creating mail.
I configured Mozilla to use only Unicode fonts for both Latin, Cyrillic and so
on. So one should expect a page mixing both Latin and Cyrillic to be rendered
with only one font. Wrong! Please see the example page using UTF-8 encoding. The
differencies between Latin letters and digits and Cyrillic letters are clearly
visible. Latin letters and digits seem bold and a little bit different.

Try to open the same pages under Windows and you won't see any difference at
all. It's clearly a Mac problem.

The same odd behaviour affects mail. Sometimes Cyrillic looks great and Latin
parts are gray and not black, sometimes it's just the opposite. Under Windows
the whole text uses the same font and looks identical.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
The linked page is NOT (as of now) in UTF-8 encoding. Rather it's Windows-1251
(or similar) encoding.
Reporter - can you provide a URL which uses UTF-8 and exhibits the problem? Or
was the problem not on UTF-8 pages to begin with?

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Why was this confirmed?  It doesn't have a simplified testcase, and I'm
skeptical that it's even valid given our font preference scheme.  And it's in
the wrong component (should probably be style system or maybe Gfx, but then
again it's hard to tell since I don't think it's valid).
Assignee: layout.fonts-and-text → nobody
QA Contact: ian → layout.fonts-and-text

Comment 3

2 years ago
Mac font rendering now matches.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.