Back sends you too far back sometimes

VERIFIED WORKSFORME

Status

()

defect
P3
normal
VERIFIED WORKSFORME
20 years ago
11 years ago

People

(Reporter: flygirl, Assigned: radha)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
eg:
goto www.yahoo.com (this works best on a slow connection :P)

Wait for the page to fully load. Then click on any link.

Quickly click on any link in the next page before the it fully loads.

Then wait for this page to fully load, click back. You should end up
back at www.yahoo.com.

Your milliage may vary due to another bug in that a link doesn't get followed
sometimes untill the page is fully loaded. :)

Updated

20 years ago
Target Milestone: M15

Comment 1

20 years ago
M15 ...

Comment 2

20 years ago
This looks like it could be a DUP of bug 13329 "Generic problem with history -
skips pages when going back", FIXED, or it could be a reason to REOPEN
that bug, depending on what build this problem was observed on.

This could also be a problem similar to bug 18798 "[WEBSHELL] Crash in
restoring frame state after hitting back" - the yahoo page may be
complex enough to trigger that problem. It may make sense to re-test
for this problem after bug 18798 is fixed.

flygirl@sinesurf.co.nz, could you please review the Bug Writing Guidelines and
provide the information listed there, in particular the build ID
(found at the right-hand-end of the status bar):
http://www.mozilla.org/quality/bug-writing-guidelines.html
Please enter that information directly into the bug report - use the
URL at the top of this bug report update e-mail to get there.
Thanks!
Status: NEW → ASSIGNED
Can't reproduce in latest builds. Marking worksforme
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME

Comment 4

20 years ago
worksforme with the 2000031009 builds. marking VERIFIED
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.