DNS: entries do not expire with their TTL

VERIFIED DUPLICATE of bug 151929

Status

()

defect
VERIFIED DUPLICATE of bug 151929
16 years ago
16 years ago

People

(Reporter: zorzella, Assigned: darin.moz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.5) Gecko/20031007

As a solution to bug 162871 (where DNS entries were cached forever), DNS entries
were made to expire in a predetermined (albeit configurable) time, still
ignoring the TTL. See that bug for further background, and, in particular,
remarks 83, 85 and onwards:

http://bugzilla.mozilla.org/show_bug.cgi?id=162871#c83
http://bugzilla.mozilla.org/show_bug.cgi?id=162871#c85

Altough it is my beleif that the original bug as I reported is still valid, I
was asked to report a new bug.

What should happen, in my opinion, is that Mozilla's APIs should allow it to
know the TTL for each DNS resolution, so it may cache it for the extent of TTL.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

16 years ago
>What should happen, in my opinion, is that Mozilla's APIs should allow it to
>know the TTL for each DNS resolution, so it may cache it for the extent of TTL.

if you know how to do this on all platforms please let me know.  note: mozilla
does not implement the DNS protocol.  we use the operating system's API,
gethostbyname or getaddrinfo on more modern OS's.

this bug is a duplicate of bug 151929.  my apologies for not pointing out the
existance of this bug already.  please see bug 223861 which covers reducing
mozilla's default TTL as a stopgap approximate solution.  until such time as
mozilla has access to DNS TTL, there is little more we can do.

*** This bug has been marked as a duplicate of 151929 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
This is, indeed, a duplicate of bug 151929. Thanks.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: Networking: Cache → Networking
QA Contact: cacheqa → benc
Summary: Cached DNS entries do not expire with their TTL → DNS: entries do not expire with their TTL
You need to log in before you can comment on or make changes to this bug.