If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"marked a duplicate" messages cannot be localized

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
User Interface
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Vlad Dascalu, Assigned: Max Kanat-Alexander)

Tracking

({intl})

unspecified
Bugzilla 3.0
Dependency tree / graph
Bug Flags:
approval +
blocking3.0 -

Details

Attachments

(1 attachment, 2 obsolete attachments)

6.14 KB, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
When someone marks a bug as a duplicate of another bug, then in both bugs a
comment is posted that notifies the CC list about the action. However, in that
comment, the term "bug" is not customized and it should be replaced with the
customized terms that are defined in the template system.

Comment 1

13 years ago
This still exist in 2.18.1.  There are (at least) two messages

*** Bug 23 has been marked as a duplicate of this bug. ***
*** This bug has been marked as a duplicate of 21 ***

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
This is also an issue for localization – the hardcoded string cannot be
translated. (I'd wanted to add l12y to the keywords list, but it seems I am not
'empowered' enough. ;-) )
Keywords: intl
Depends on: 297104

Updated

11 years ago
QA Contact: mattyt-bugzilla → default-qa
(Assignee)

Updated

11 years ago
Assignee: myk → mkanat
Summary: Customized "bug" term when generating "has been marked a duplicate" messages → "marked a duplicate" messages cannot be localized
Target Milestone: --- → Bugzilla 3.0
(Assignee)

Comment 3

11 years ago
Created attachment 238388 [details] [diff] [review]
v1

Okay, here. This fixes it.
Attachment #238388 - Flags: review?(LpSolit)
(Assignee)

Comment 4

11 years ago
Oh, and I did test the above patch.
Status: NEW → ASSIGNED
Problem is that this breaks autolinkification...
(Assignee)

Comment 6

11 years ago
(In reply to comment #5)
> Problem is that this breaks autolinkification...

  True. We do have a bug filed to customize autolinkification, somewhere, I think.

  Either that, or we should just eliminate these messages, since the data is stored in the bugs_activity table anyway.

  Usually people only change terms.bug once, and they also customize the code to highlight it, but that's not always the case.

  I could use get_text to get the current "bug" term, for autolinkification, also.
(In reply to comment #6)
>   Either that, or we should just eliminate these messages, since the data is
> stored in the bugs_activity table anyway.

Did you hear the cryout when the comment from an added attachment when creating a bug was found missing?
I believe people will want these comments on their bugs...

>   I could use get_text to get the current "bug" term, for autolinkification,
> also.

This would be great!

Comment 8

11 years ago
Comment on attachment 238388 [details] [diff] [review]
v1

I agree with Marc, autolinkification is a problem here. This has nothing to do with terms.bug but with the entire string itself, see Bugzilla::Template::quoteUrls() at line 344.
Attachment #238388 - Flags: review?(LpSolit) → review-
fix bug 191362 then the issue will have gone B-)
(Assignee)

Comment 10

11 years ago
Created attachment 238477 [details] [diff] [review]
v2

Okay, this fixes it--now the highlightable term can be customized.
Attachment #238388 - Attachment is obsolete: true
Attachment #238477 - Flags: review?(LpSolit)
(Assignee)

Comment 11

11 years ago
Created attachment 238478 [details] [diff] [review]
Actual v2

That other one was the wrong patch.
Attachment #238477 - Attachment is obsolete: true
Attachment #238478 - Flags: review?(LpSolit)
Attachment #238477 - Flags: review?(LpSolit)

Comment 12

11 years ago
Comment on attachment 238478 [details] [diff] [review]
Actual v2

works fine. r=LpSolit
Attachment #238478 - Flags: review?(LpSolit) → review+

Updated

11 years ago
Flags: approval?
Flags: approval? → approval+
(Assignee)

Comment 13

11 years ago
Checking in Bugzilla.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla.pm,v  <--  Bugzilla.pm
new revision: 1.50; previous revision: 1.49
done
Checking in process_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/process_bug.cgi,v  <--  process_bug.cgi
new revision: 1.342; previous revision: 1.341
done
Checking in Bugzilla/BugMail.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/BugMail.pm,v  <--  BugMail.pm
new revision: 1.91; previous revision: 1.90
done
Checking in Bugzilla/Template.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Template.pm,v  <--  Template.pm
new revision: 1.62; previous revision: 1.61
done
Checking in Bugzilla/Util.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Util.pm,v  <--  Util.pm
new revision: 1.54; previous revision: 1.53
done
Checking in template/en/default/global/messages.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/messages.html.tmpl,v  <--  messages.html.tmpl
new revision: 1.45; previous revision: 1.44
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 14

11 years ago
um. i bet i don't like the way this is fixed.

if bugzilla has 5 locales, what locale is used for the message?
(Assignee)

Comment 15

11 years ago
(In reply to comment #14)
> if bugzilla has 5 locales, what locale is used for the message?

  The locale of the user performing the change.

  This is why comments just shouldn't contain this information at all.

  You can file another bug about that, if you want.

Updated

11 years ago
Blocks: 353656

Comment 16

11 years ago
this should be backed out for the reasons specified in comment 14, comment 15, and bug 353656.
No longer blocks: 353656

Comment 17

11 years ago
i think i managed to convince colin that this is doing more harm than good. i'm setting this to blocking because i want it on the radar of things that needs to be backed out. i don't know of some other way to do it.
Flags: blocking3.0?
(Assignee)

Comment 18

11 years ago
No, bug 353656 is a blocker, not this bug.

Don't use CVS HEAD or a development release if you don't want things to break.
Flags: blocking3.0? → blocking3.0-

Updated

10 years ago
Blocks: 392821
You need to log in before you can comment on or make changes to this bug.